cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

NET (Agent, Installation)

.Net Data Collector

SOLVED

.Net Data Collector

I have a Transaction/Analytics Data Collector configured that returns the correct data in transaction snapshots, but does not display it correctly in an Analytics search.

DC: APR_PackageNames

I do not readily have access to the Devs and source code, is there a way that I can return the Collector corretly in Analytics, like how it looks in Snapshots?
If the collector is returning a string awway, how can I convert it in the field where I define my getter in Analytics?

*Update
Controller and .Net agents version  4.4.1.0

See photos below.

Image 004.pngImage 005.pngImage 009.png

By replying you agree to the Terms and Conditions of the AppDynamics Community.
.Net Data Collector
7 REPLIES 7
Chitra.Lal
AppDynamics Team

Hi Dietrich,

 

No, we cannot define getter in analytics, neither can we change the data type in Analytics, it will show you whatever format it receives a value in; No external conversions are possible. 

 

Are you setting a getter chain in thetransaction snapshots data collector config so you are getting the correct values? Can you share a screenhsot of the APM side data collector.

 

 

Thanks,

Chitra

 

 



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Hi Chitra

 

Thanks fort clarifying on the conversions.

We only defined one data collector and turned it on for Snapshots and Analytics.
See below.

Image 002.png

Config screenshots attached below.

My main issue is that the Collector resturns the correct data in the snapshots, but not in the Analytics Module, even when it is the one collector.

Image 003.pngImage 004.png

Chitra.Lal
AppDynamics Team

Hi Dietrich,

 

It should report same value at both the places; Can you try setting the getter chain as, PackageNames().toString() in the data collector config and see if that helps.

 

Thanks,

Chitra

 



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Hi

 

I am also expecting it to return the same at both places but it is not.

I tried using PackageNames().toString() but it then complains about the following:


Image 002.pngImage 002.png

Update:

 

Think I found a solution by using .NET Framework Class Library methods.

 

Original: PackageNames()


New: PackageNames().GetValue(0)

Chitra.Lal
AppDynamics Team

Hi Dietrich,

 

Really glad to know that. Would you mind clarifying where did you add this getter chain, PackageNames().GetValue(0) : in the data collector config or in your code? 

 

 

Thank You,

Chitra



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Hi

 

Is was in the data collector config.

 

Image 001.png