cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

NET (Agent, Installation)

Agent version is newer than controller version

SOLVED
Basit.Awan
Wanderer

Agent version is newer than controller version

why i am getting this errror "Agent version is newer than controller version" how to fix ? 

 

AgentVersion.JPG

By replying you agree to the Terms and Conditions of the AppDynamics Community.
Agent version is newer than controller version
4 REPLIES 4

Hi Basit, 

 

Only language agents (Java, .NET etc) are backwards compatible, from the downlaod page:Selection_730.jpg

 

You will have to go back to 4.4 version of the agent.

 

Regards, 

Nic

Indrajit.Shah
Builder

Hi Basit.Awan

 

I beleive it will fix the issue if you update the controller or elso you have to downgrade the Agent version.

Shah, Indrajit Kumar
Basit.Awan
Wanderer

Thank you for the reply. Where to get 4.4 agent?

Hi Basit, 

 

On the downloads page there is an option to choose the version:Selection_742.jpg