Java (Java Agent, Installation, JVM, and Controller Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

Remote Services detection

Producer

Remote Services detection

We have an issue with the remote services traffic detection.-

If we check the transaction flow map, we can see all the remote service calls executed from the tiers, and associated to that BT.

However, those HTTP exit calls appears listed in the remote service list, but with number of call 0.

Also in the application flow map and in the tier flow map, those calls are missing... However if we check the nodes  or the own tier, selecting the "Slowest DB & Remote Service Calls", then we can see a list including some of those HTTP calls...

 According to docs, the tier and node flow maps, also the Tier dashboard flow map, should be display those metrics, but only the BT flow map is displaying them.

 The tool is detecting the traffic, because remote services are listed and slowest calls have metrics, however the flow maps do not include those backends and remote service list calls column always appears with 0 value...

 Do you know why is the issue here?

Thanks a lot in advance!

Remote Services detection
3 REPLIES
Community Manager

Re: Remote Services detection

Hi @Maria.Garcia

 

What version of the Controller are you on?

 

Please share specifics of your environment so we can investigate closely.


Thanks,
Radhika P




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Producer

Re: Remote Services detection

The AppDynamics version is 4.3.8.5

 

The remote services traffic is detected, but only the business transaction view and BTs flow map show those calls...

It seems a visualization issue or someyhing like this...

It has no sense that remote services are listed but no traffic is assigned to them...

Thanks

Producer

Re: Remote Services detection

Hi,

 

On the other hand, we have detected that the issue could be related with backend naming.

I mean, if a remote service is detected as host1:port1 and then backend naming configuration is modified to add a segment (for example host1:port1/segment1), the calls seems not being properly assigned and then both names are displayed, but with 0 calls.

 

The same result is detected if we have the following:

host1:port1/segment1

host1:port1/segment2

host1:port1/segment3

The HTTP remote services are listed, but with 0 calls...

 

Could this be possible?

How to avoid this issue please?

Thanks!