Java (Java Agent, Installation, JVM, and Controller Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

Machine Agent status in Appdynamics UI shows as 0

Highlighted
Explorer

Hi,

 

I am finding Machine Agent status 0 in the Appdynamics UI for a particular Tier/Node. As a result, none of the metrics like CPU %, Memory, etc are not reporting any data for that application.

 

The hosting server is RHEL OS, having both Machine agents and Java Agent installed.

Machine Agent version: 4.5.1

Java Agent Version: 4.5.10

 

Machine agent logs do not show any errors related to this application.

Also, I have recently upgraded the Java Agent version from 4/3.x to 4.5.10. Apparently the issue is happening since then.

 

How can I troubleshoot the issue? Please suggest.

 

Regards

Shweta

Machine Agent status in Appdynamics UI shows as 0
4 REPLIES 4
Highlighted
Community Manager

Hi @Shweta.Damam,

 

It seems there is a newer version of the Java agent available if you wanted to update to the latest version and see if the issue still remains

 

You can visit the download page here.

 

Do let me know if that helps. If you gain any learnings from this, please share them back on this community post so other members can see.


Thanks,
Ryan, AppDynamics Community Manager




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
Explorer

Hi Ryan,

 

Thank you for the response . I will try installing the new version .

 

However , when I tried adding the system property -Dappdynamics.agent.uniqueHostId

in JVM opts of the application I am able to see the Machine agent reporting the hardware metrics ,

but if I add <unique-host-id> to the Machine agent's controller-info.xml file , instead,  the machine agent stopped working again .

 

Would you suggest any workaround ?

 

Regards

Shweta

Tags (1)
Highlighted
Community Manager

Hi @Shweta.Damam,

 

I don't know the answer to that at this time. If I find any information I will be sure to reply back to this thread. If you find any useful information, please do share it back on this thread so the community may benefit as well. 


Thanks,
Ryan, AppDynamics Community Manager




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
New Poster

Hi @Shweta.Damam 

Can you please ping the exact command of how you are trying to start a machine agent? If you are trying with nohup, check nohup.out file if you see any info? Also please check machine agent licenses and Server visibility license in case if you have enabled SIM?

Thanks,
Ashok