Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to start on-prem controller


Trying to start on-prem controller, getting this error:


[root bin]# ./ start-appserver
[INFO] Path to mysql is not defined in system environment (MYSQL_BIN). Using mysql from /data/appdynamics/controller/db/bin

[INFO] Mysql configuration file is not defined in system environment (AD_DB_CNF). Using mysql configuration file: /data/appdynamics/controller/db/db.cnf

[INFO] Mysql datadir is /data/appdynamics/controller/db/data
[#|2020-05-18T16:18:54.496-0400|WARNING|5.1.1|imq.log.Logger|_ThreadID=1;_ThreadName=main;|[S2004]: Log output channel com.sun.messaging.jmq.util.log.SysLogHandler is disabled: no imqutil in java.library.path|#]

[#|2020-05-18T16:18:54.508-0400|SEVERE|5.1.1|imq.log.Logger|_ThreadID=1;_ThreadName=main;|ERROR [B3103]: is not jdbc type:
com.sun.messaging.jmq.jmsserver.util.BrokerException: [B3103]: is not jdbc type at com.sun.messaging.jmq.jmsserver.persist.jdbc.comm.CommDBManager.initDBManagerProps(
at com.sun.messaging.jmq.jmsserver.persist.jdbc.DBManager.<init>(
at com.sun.messaging.jmq.jmsserver.persist.jdbc.DBManager.getDBManager(
at com.sun.messaging.jmq.jmsserver.persist.jdbc.DBTool.doCommand(
at com.sun.messaging.jmq.jmsserver.persist.jdbc.DBTool.main(

Starting controller application server in default mode...

nohup: ignoring input and redirecting stderr to stdout
***** Controller application server started. Login URL is http://localhost:8090/controller *****


But the controller UI never loads. 


Community Manager

Hi @Diane.Volkmar,


Sorry, you are having this trouble. I found this Knowledgebase article that provides some FAQs in this situation.


If you learn anything from that article, please so share that knowledge back on your post. This allows the community to increase its knowledge bank of answers.


Ryan, Cisco AppDynamics Community Manager

Found something helpful? Click the Accept as Solution button to help others find answers faster.

Liked something? Click the Thumbs Up button.

Check out Observabiity in Action

new deep dive videos weekly in the Knowledge Base.

Hi Ryan,

Thanks for that link. I tried stopping and starting each component separately, as suggested:

  shell> cd <Controller_install_dir>/bin
  shell> ./ stop-appserver
  shell> ./ stop-db

  shell> ./ start-db
  shell> ./ start-appserver

But still had the same error on the start-appserver. I tried several times and verified each command did what it was supposed to. Finally, I brought up the Enterprise Console, and stopped and started the Controller from there, and it started successfully. Not sure if the EC does something different than the command line, or if it was just a timing issue, but it's currently up and running.


im facing the same problem. do you have any idea or workaround to solve this problem ?




The workaround is to bring up the Enterprise Console, and stop and start the Controller from there, instead of using command line commands. We have since migrated to a SaaS server, so we no longer have an on-prem controller.