Controller (SaaS, On Premise)

Showing results for 
Search instead for 
Did you mean: 

installing Events service in different host


installing Events service in different host

I'm trying to install the Events service from the Console host:


my configuration 

1-  host has been added successfully  and ssh "passwordless"  which is the other host

2- Java_Home variable is defined in both hosts 

3- vim /etc/security/limits.d/appdynamics.conf

4- checked the error directory  path and found "/opt/appdynamics/platform/product/orcha/" 

5- running both commands from the enterprise console host and both give me the same error 


 bin/ install-events-service --profile prod --hosts --data-dir /opt/appdynamics/eventsservice --platform-name AppDPlatform 

./bin/ submit-job --service events-service --job install --args serviceActionHost= profile=Prod 





[root@console platform-admin]# bin/ install-events-service --profile prod --hosts --data-dir /opt/appdynamics/eventsservice --platform-name AppDPlatform
Installing Events Service on new nodes.
( 1/ 26) Clean up orphaned Events Service: SUCCESS
( 2/ 26) Register Events Service Lifecycle Listener before installing: SUCCESS
( 3/ 26) Validate and set parameters while installing ES: SUCCESS
( 4/ 26) Setup cluster configuration: SUCCESS
( 5/ 26) Initialize Events service cluster: SUCCESS
( 14/ 26) Set JRE Versions: SUCCESS
( 15/ 26) Check Events Service hostnames: SUCCESS
( 16/ 26) Verify hosts: FAILED
Events Service installation failed.
Failure occurred: Verify hosts
Error message:
Task failed: Facts collection
on host:
as user: root
with message: Error occurred while executing the task [facts].
env: /opt/appdynamics/platform/product/orcha/ No such file or directory


Solution Architect
installing Events service in different host

Re: installing Events service in different host

Hi Abdulrahman


I think something went wrong, possibly when you first tried to add it.


For this error, the following will normally work


bin/ remove-dead-hosts --hosts <host name>


Then re-add the host again, and it should now work 


If not, let us know:)



Learn more about me in the Community Member Spotlight Q & A