NET (Agent, Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

How to have multiple custom rule for a .NET POCO

Highlighted
Creator

Re: How to have multiple custom rule for a .NET POCO

I had excluded the Auto discovered Endpoint and created POCO rules for the child BT with higher priority.

Asp.net Custom Match Rule for parent BT with lower priority.

This did not work.

New Poster

Re: How to have multiple custom rule for a .NET POCO

BT: Asp.net

 

Here are the steps I did:

1. Verify that custom BT has a higher priority than the auto-discovery rule. (custom-BT-With-Higher-Priority.png)

 

2. Verify that auto-discovery is enabled for asp.net (auto-detect-on.png)

 

3. run test that uses the custom BT. This did not show up in the business transcation list. (Bt-With-auto-detect-on.png)

 

4. Turn off auto-detect for asp.net requests Disable-auto-discovery.png)

 

5. run the same test again that uses the custom BT.

 

6. Notice that it now shows up... (Custom-Bt-After-Disable.png)

 

 

Now the question is why does it show up only after I have disabled auto-detect? I have verified that no other BT in that list uses this chain. And based on AppD documentation, it should show up regardless. 

 

Let me know if you need anything else. We should look more into this to understand the root cause of the problem.

 

Thanks