cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Deepanshu.Grover
AppDynamics Team (Retired)

Symptoms

Transaction Analytics stops getting data even when all configuration is in place.

 

When the analytics-agent.log is checked, the following stacktrace could be captured:

[ERROR]  [dw-15387 - POST /v2/sinks/bt]  [c.a.a.p.http.AbstractPostReceiver]  Request could not be processed as the input queue is full

...

[c.a.a.a.p.e.EventServicePublishStage] Transient error encountered due to the following cause: [Message could not be delivered because the REST resource rejected it]
com.appdynamics.analytics.shared.rest.exceptions.NotAcceptableRestException: For action [EVENT_UPSERT], you have reached the documents limit of [500000] for account [Account_name] and event type group [biz_txn_v.*]
 at com.appdynamics.analytics.shared.rest.exceptions.RestExceptionFactory.makeException(RestExceptionFactory.java:47) ~[analytics-shared-rest.jar:na]


Once day limit is revised the data starts showing.

 

Diagnosis

This issue occurs because the number of transaction events reported in Transaction Analytics is more than 500,000 per unit (up to version 4.2.9) or 1,000,000 per unit (from version 4.2.9 and beyond). 

 

The number of transactions is governed by your license, which sets the daily per-unit limit. Once the daily limit is reached, no further events will be stored.

 

Analytics License basis and entitlements by version

Analytics licenses are based on the following:

  • Volume of data: 
    • Transaction Analytics: Measured as a specific number of Business Transaction events.  
    • Data retention time

 

Entitlements for v4.2.9 and later

The following entitlements apply to the AppDynamics software versions 4.2.9 and later:

AppDynamics for Transaction Analytics (SaaS) Instrument 1,000,000 business transaction events per 24-hour period and access to the AppDynamics-hosted Events Service, with a data maximum of 50 GB per account per day. Data retention limited to 8 days. Additional retention of 30, 60, or 90 days available as an add-on.
AppDynamics for Transaction Analytics (on-premises) Instrument 1,000,000 business transaction events per 24-hour period (limited to 90 days of data storage). Customer is not entitled to access the AppDynamics-hosted Events Service.

 

Entitlements up to v4.2.9

The following entitlements apply up to v4.2.9

AppDynamics for Transaction Analytics (SaaS) Instrument 500,000 business transaction events per 24-hour period and access to the AppDynamics-hosted Events Service, with a data maximum of 50 GB per account per day. Data retention limited to 8 days. Additional retention of 30, 60, or 90 days available as an add-on.
AppDynamics for Transaction Analytics (on-premises) Instrument 500,000 business transaction events per 24-hour period (limited to 90 days of data storage). Customer is not entitled to access the AppDynamics-hosted Events Service.


Solution

That's the reason you see those consistent gaps which start showing data once the day limit is revised.

 

To resolve this you can get a license for higher unit limits, which will log higher number of events. You can also try reducing your events data.

Version history
Last update:
‎11-06-2020 10:56 AM
Updated by:
On-Demand Webinar
Discover new Splunk integrations and AI innovations for Cisco AppDynamics.


Register Now!

Observe and Explore
Dive into our Community Blog for the Latest Insights and Updates!


Read the blog here