cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to start javaagent

Shwetha.Gattu
Creator

Hi,

When using jdk8+ javaagent version 22.12.0, 

I see below error

$ java -javaagent:/cache/javaagent.jar -version

Unable to locate appagent version to use - Java agent disabled

openjdk version "1.8.0_382"

OpenJDK Runtime Environment (Zulu 8.72.0.17-CA-linux64) (build 1.8.0_382-b05)

OpenJDK 64-Bit Server VM (Zulu 8.72.0.17-CA-linux64) (build 25.382-b05, mixed mode)

 

What is the compatible javaagent version for above Java version.

3 REPLIES 3

Cansel.OZCAN
Maker

Hi Shwetha,

Can you please give some details about your scenario.?

What is your aim to use java agent ?

Thanks

Cansel

 

Hi Cansel,

A Spring boot application in Kubernetes pod is brought up with javaagent of appdynamics to track the metrics.

The base image of container has Azul Zulu Java 1.8 and we need compatible version of appdynamics javaagent.jar to get it working.

We have license and have a SaaS controller setup to track the events.

 

Thanks,

Shwetha

Shwetha.Gattu
Creator

Any update @Cansel.OZCAN?