Java (Java Agent, Installation, JVM, and Controller Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

Java Agent 4.5 compatibility with Weblogic 12.2.1.3.0

Java Agent 4.5 compatibility with Weblogic 12.2.1.3.0

Hi ,

 

Upgraded Appd server agent from 4.2.13 to 4.5.6 in our weblogic servers.After the upgrade , managed servers are failed to start ? Can someone take a look on below error?

 

Error:

--

<Feb 20, 2019 6:01:11,980 PM UTC> <Error> <CoherenceIntegration> <BEA-2194507> <The Coherence cluster service failed to start or failed to join cluster due to (Wrapped) java.lang.ClassFormatError: Illegal field modifiers in class com/tangosol/net/Invocable: 0x1A using Exception configuring coherence..>

---

Env's:
Weblogic 12.2.1.3, OS Redhat 7.4, JDK 1.8.0_131

Java Agent 4.5 compatibility with Weblogic 12.2.1.3.0
3 REPLIES 3

Re: Java Agent 4.5 compatibility with Weblogic 12.2.1.3.0

Hello,

 

Did you solved this problem? I have a similar one:

SEVERE: Exception sending context initialized event to listener instance of class [lumis.portal.PortalConfiguration]
java.lang.ClassFormatError: Illegal field modifiers in class lumis/portal/cluster/IClusterCallable: 0x1A

Using Tomcat 8.5 and Java Agent 4.5.7

Re: Java Agent 4.5 compatibility with Weblogic 12.2.1.3.0

Nope Still not able to fix it.

Highlighted

Re: Java Agent 4.5 compatibility with Weblogic 12.2.1.3.0

 

Add below lines inside <bci-processing-excludes> section in app-agent-config.xml & try it out.

 

<custom-exclude filter-type="STARTSWITH" filter-value="lumis.portal.cluster.IClusterCallable"/>