Java (Java Agent, Installation, JVM, and Controller Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

App agent is not starting on WebLogic application

Highlighted

App agent is not starting on WebLogic application

I have set the path to the AppD agent jar in the startWeblogic.cmd script like:

set JAVA_OPTIONS=%JAVA_OPTIONS% -javaagent:"%APPDHOME%\javaagent.jar"

just before the line for starting weblogic.

 

In the cmd output of WebLogic I can see that the javaoptions are set correctly and the AppD agent property is present but I don't see it running, so there are no messages on the console about actually starting the AppD agent at all. Also, no log files are generated.

 

What can I do to make the WebLogic start the AppD agent?

App agent is not starting on WebLogic application
4 REPLIES 4
Moderator

Re: App agent is not starting on WebLogic application

Can you try putting the -javaagent option at the start of the java options, rather than at the end?



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Re: App agent is not starting on WebLogic application

Still the same situation. Here is the java line:

C:\Oracle\MIDDLE~1\JDK160~1\bin\java -javaagent:"C:\AppServerAgent\javaagent.ja
r" -client -Xms512m -Xmx1536m -XX:MaxPermSize=128m -Dweblogic.Name=AdminServer
-Djava.security.policy=C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.policy
-Xverify:none -da -Dplatform.home=C:\Oracle\MIDDLE~1\WLSERV~1.3 -Dwls.home=C:
\Oracle\MIDDLE~1\WLSERV~1.3\server -Dweblogic.home=C:\Oracle\MIDDLE~1\WLSERV~1.3
\server -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testCon
sole= -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=C:\Oracle\MIDDLE~1\patch_wls
1036\profiles\default\sysext_manifest_classpath;C:\Oracle\MIDDLE~1\patch_oepe180
\profiles\default\sysext_manifest_classpath;C:\Oracle\MIDDLE~1\patch_ocp371\prof
iles\default\sysext_manifest_classpath;C:\Oracle\MIDDLE~1\patch_adfr1111\profile
s\default\sysext_manifest_classpath weblogic.Server

Moderator

Re: App agent is not starting on WebLogic application

Can you confirm:

  1. is your WebLogic server is running fine
  2. do you have any agent logs written under C:\AppServerAgent\ver4.x.y.z\logs? (these will be in a directory named after the AppD node name)

Is there anything relating to the AppDynamics agent in the WebLogic boot log?

 

I also note this is your WebLogic admin server you have instrumented.  You are likely to get more interesting results from one of the managed servers where your app is running (unless this is a single server installation), although there is no reason that instrumenting the admin server should not work.



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Re: App agent is not starting on WebLogic application

Hi,

 

1. Yes, it is running fine - I don't see any issues with it.

2. No - no logs generated at all. Only way I can make it write something is if I run directly java with -javaagent but it exits immediately after start, of course.

 

I don't see anything related with AppD in the weblogic logs.

It is a single server installation. And also it is more like a test setup so I just need to get any data from the agent...