Reply
Moderator
Posts: 20
Registered: ‎03-09-2015

Re: error from adrum_latest.js

Hi Jakub,

 

For on-prem EUM we suggest using specific version of the adrum script. You can download it to your environment, or you can source it from the CDN like https://cdn.appdynamics.com/adrum/adrum-4.2.10.0.js.

 

https://cdn.appdynamics.com/adrum/adrum-latest.js is updated constantly and works best with EUM on SaaS which is always at the latest version.

 

Hope this helps.

 

Regards,

Mayuresh

Contributor
Posts: 18
Registered: ‎03-09-2017

Re: error from adrum_latest.js

how about getting the concrete version from CDN? or you're not planning any breaking changes, so the adrum_latest should be fine at any time? or you have some adrum_4_latest link, assuming you're following semver versioning, so if any breaking change happens, it will be in the version 5+

Contributor
Posts: 18
Registered: ‎03-09-2017

Re: error from adrum_latest.js

oh, sorry, that was stupid mistake :)

 

J.

Community Manager
Posts: 49
Registered: ‎06-06-2016

Re: error from adrum_latest.js

Jakub,

Looks like you have missed the new keyword

 

`ADRUM.events.VPageView({url:"anything"});` should be `new ADRUM.events.VPageView({url:"anything"});`

 

Regards,

Mohammed Rayan

Highlighted
Contributor
Posts: 18
Registered: ‎03-09-2017
Accepted Solution

error from adrum_latest.js

[ Edited ]

Hi,

 I am trying to set up proper virtualPage tracking .. and I have some questions :)

 

according to this documentation, new page object should be created as:

 

ADRUM.events.VPageView({url:"anything"});

but it fails:

 

ADRUM.events.VPageView({url:"anything"})
adrum-latest.js:19 Uncaught TypeError: this.timestamp is not a function
    at Object.d [as EventTracker] (adrum-latest.js:19)
    at Object.b [as VPageView] (adrum-latest.js:57)
    at <anonymous>:1:14

we're using directly version linked from CDN, as you can see in the screenshot .. so maybe there is bug in latest version?

 

before we switched to the script from CDN, we used downloaded adrum.js file .. I see it had version 4.2.9.2, but current latest from CDN is 4.2.10.0 .. so I thought maybe there was some breaking change so I tried to get the 4.2.9.2 from CDN ..

 

according to this documentation it should at this url:

https://cdn.appdynamics.com/adrum/adrum-4.2.9.2.js

but it isn't .. so is adrum_latest.js safe for us?

 

thanks!

 J.

 

edit: it fails also for Ajax and Error initialization:

ADRUM.events.Error({msg:"custom triggered error"});
adrum-latest.js:19 Uncaught TypeError: this.timestamp is not a function
    at Object.d [as EventTracker] (adrum-latest.js:19)
    at Object.b [as Error] (adrum-latest.js:22)
    at <anonymous>:1:14
d @ adrum-latest.js:19
b @ adrum-latest.js:22
(anonymous) @ VM1785:1

ADRUM.events.Ajax({msg:"custom triggered error"});
adrum-latest.js:19 Uncaught TypeError: this.timestamp is not a function
    at Object.d [as EventTracker] (adrum-latest.js:19)
    at Object.e [as Ajax] (adrum-latest.js:37)
    at <anonymous>:1:14
d @ adrum-latest.js:19
e @ adrum-latest.js:37
(anonymous) @ VM1797:1