Dynamic Languages (Node.JS, Python, PHP, C/C++, Webserver Agent)

cancel
Showing results for 
Search instead for 
Did you mean: 

How to use AppDynamics(4.4/4.5) PhpAgent with Zend Opcache ?

SOLVED

How to use AppDynamics(4.4/4.5) PhpAgent with Zend Opcache ?

Hello everyone and thank you in advance for reading this topic.


I need to monitor an application under symfony 3.4 with PHP 7.1.8 which inevitably uses Zend Opcache to improve performance.

 

I know your first reflex is to look at the compatibility matrix and refer me to this article:


https://docs.appdynamics.com/display/PRO45/PHP+Supported+Environments

 

to arrive at the following remark:

 

 

Capture.PNG

 

My constraints are:

- I do not have to disable the opcache
- I have to monitor my application with Php agent

 

I just want to know if you have tips or workarounds that I can put in place to take advantage of all the power of Appdynamics to monitor my application with the constraints mentioned above.

 

I thank you in advance for your contributions and your answers.

 

M.M

Tags (2)
How to use AppDynamics(4.4/4.5) PhpAgent with Zend Opcache ?
5 REPLIES
Employee

Re: How to use AppDynamics(4.4/4.5) PhpAgent with Zend Opcache ?

Hi Mhamed,

 

Please check your DMs. (edited)

 

Best,

Kyle

Thanks,
Kyle Furlong, Technical Lead (C++ and Dynamic Languages)




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Employee

Re: How to use AppDynamics(4.4/4.5) PhpAgent with Zend Opcache ?

Whoops, I meant please *check* your DMs.

Thanks,
Kyle Furlong, Technical Lead (C++ and Dynamic Languages)




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted

Re: How to use AppDynamics(4.4/4.5) PhpAgent with Zend Opcache ?

Thank you for your return, I will test all this on my pre-prod environment and I will keep you informed.

Community Manager

Re: How to use AppDynamics(4.4/4.5) PhpAgent with Zend Opcache ?

Hi @Mhamed.Mnaouar - I have good news for you!  The PHP agent is compatible with Zend OpCache as of v4.5.2.2042. Please post back here if you have any questions and we'd be happy to help.

 


Thanks,
Nina, AppDynamics Community Manager




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Re: How to use AppDynamics(4.4/4.5) PhpAgent with Zend Opcache ?

I'm sorry to come back to you so late. However, it worked for me.