NET (Agent, Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

no metrics in controller after .net agent installation in linux centos7

Highlighted
Creator

1.Downloaded .NET Agent - 64-bit linux (AppDynamics-DotNetCore-linux-x64-4.5.17.0.zip) from https://download.appdynamics.com/download/
2.Extracted binaries from AppDynamics-DotNetCore-linux-x64-4.5.17.0.zip file into the desired folder.
3.Opened the .netcore web application using http://localhost:8000/
4.Copied libappdprofiler.so,AppDynamics.Agent.netstandard.dll and AppDynamicsConfig.json to the /opt/appdynamics/dotnet/ folder
5.Made mandatory settings required to attach the agent to the .NET application

export CORECLR_PROFILER={57e1aa68-2229-41aa-9931-a6e93bbc64d8} \
CORECLR_ENABLE_PROFILING=1 \
CORECLR_PROFILER_PATH=/opt/appdynamics/dotnet/libappdprofiler.so

export APPDYNAMICS_CONTROLLER_HOST_NAME=hcl301.saas.appdynamics.com
export APPDYNAMICS_CONTROLLER_PORT=443
export APPDYNAMICS_CONTROLLER_SSL_ENABLED=true
export APPDYNAMICS_AGENT_ACCOUNT_NAME=hcl301_04f3faa7-fa76-4cf5-ab4d-8feb8fa2f54d
export APPDYNAMICS_AGENT_ACCOUNT_ACCESS_KEY=ey8aqbrfkodq


export APPDYNAMICS_AGENT_APPLICATION_NAME=linuxcore
export APPDYNAMICS_AGENT_TIER_NAME=linuxcore
export APPDYNAMICS_AGENT_NODE_NAME=linuxcore

6. And the continuously running .netcore web application

Did not observed metrics in the appdynamics controller.

.net core agent is not communicating to controller. Using .net core 3.0 on linux.

And agent log has following warnings.

Invalid header in Http response
Agent config request error {http status 401}
Connection back off limitation in effect for config request

 

Thanks,

kri

Tags (2)
no metrics in controller after .net agent installation in linux centos7
1 REPLY 1
Highlighted
Architect

Person right above you had the same issue here was my response to them:

 

If it's complaining about HTTP then there there might be an issue with your AppDynamicsConfig.json. Can you vi back into it and make sure you set it to point to the Controller correctly?

 

This doc may help: https://docs.appdynamics.com/display/PRO45/.NET+Agent+for+Linux+Advanced+Configuration+Options

 

Pay special attention to the ports you're using also to make sure they're not blocked, and that you're using the correct ones whether you're using SSL or not. Another place to check would be the cert trust.





Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.