NET (Agent, Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

AppDynamics profiler compatibility issue with .Net Core 2.1

SOLVED
New Poster

AppDynamics profiler compatibility issue with .Net Core 2.1

Hi I work at Microsoft on the .NET runtime team and I wanted to reach out about an issue that was reported to us here: https://github.com/dotnet/coreclr/issues/18448.

I've already debugged the issue and I've got a tentative fix. If possible I'd love to coordinate with someone from AppDynamics in case you've got questions and to help get this resolved as best we can for customers.

Thanks!

 -Noah Falk

AppDynamics profiler compatibility issue with .Net Core 2.1
5 REPLIES
Employee

Re: AppDynamics profiler compatibility issue with .Net Core 2.1

Noah,

 

Thank you very much for contacting us about this issue! Our .NET engineering team will be reaching out to you next week. If you could email me at cody.naumann@appdynamics.com I can pass your information along to the engineering and product managers.

 

Best regards,

 

Cody Naumann

 

 

Highlighted
Architect

Re: AppDynamics profiler compatibility issue with .Net Core 2.1

Is there any immediate workaround suggested from AppDynamics until the issue is released as a Hotfix?
Moderator

Re: AppDynamics profiler compatibility issue with .Net Core 2.1

Hi,
The issue that you have highlighted will be fixed in future releases but be aware that .Net Core 2.1 is not supported yet as the framework level APIs have changed. Devs are working towards adding this support but we do not yet have any timelines when this support will be GAd.

Thanks,
Raunak


Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Employee Alumni (Retired)

Re: AppDynamics profiler compatibility issue with .Net Core 2.1

Huge thanks to @noahfalk for proactively reaching out to AppDynamics engineering and partnering with us on these fixes. We had a productive conversation which I believe will help us get robust support for .NET Core 2.1 out the door. Specifically, we are working on uptaking the async/await and ASP.NET Core 2.1 changes. Look for feature updates coming soon. Please reach out again if you have further questions on GitHub or the AppDynamics Community.

 

Meera Viswanathan
Senior Product Manager, AppDynamics - .NET And Azure

Community Manager

Re: AppDynamics profiler compatibility issue with .Net Core 2.1

@noahfalk @Abhinav.Galodha Thank you both for reaching out about this. I have good news - As of v4.5.1, the AppDynamics .NET Agent now supports .NET Core 2.0 and 2.1. Please feel free to reply here if you have any further questions about this.


Thanks,
Nina, AppDynamics Community Manager




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.