Knowledge Base

cancel
Showing results for 
Search instead for 
Did you mean: 

Why am I unable to get JMX metrics from a GlassFish Server?

In some situations, JMX metrics from GlassFish are not reported. Also, some metrics may not be enabled by default. Try this solution:

 

  1. Confirm that JMX monitoring is enabled in the GlassFish server. 
  2. Navigate to the <agent_home>/ver<version_number>/conf/jmx/ directory. 
  3. Copy the attached XML into an mbean-servers.xml file in that directory. 

You should see a new JMX node in the metrics tree.

Version history
Revision #:
2 of 2
Last update:
‎11-19-2018 01:56 PM
Updated by:
 
Labels (1)
Contributors
Tags (2)
0 Kudos