Knowledge Base

cancel
Showing results for 
Search instead for 
Did you mean: 

What does the "Time range not supported error" mean?

Symptoms

Issue:  Time range not supported error

 

Time_Range_Not_Supported.png

Diagnosis

Log in into the controller database and verify the following properties:

 

  • <Controller_Install_Dir>\bin\controller[.sh/.bat] login-db
  • select name, value from global_configuration_cluster where name in ('disable.historic.transactional.flow', 'caches.retention.period');

You might see an output like the following:

+-------------------------------------+-------+
| name | value |
+-------------------------------------+-------+
| caches.retention.period | 24 |
| disable.historic.transactional.flow | true |
+-------------------------------------+-------+
2 rows in set (0.00 sec)

 

Solution

If the disable.historic.transactional.flow is set to true, then the controller will display a maximum of up to 24 hours, defined by caches.retention.period.

 

To modify this setting, log in to the controller admin console, and mark the disable.historic.transactional.flow value as false. For details about logging in, see: https://docs.appdynamics.com/display/PRO41/Access+the+Administration+Console

 

To confirm this change, log out of the controller, then log in to the controller and check the behavior.

 

Version history
Revision #:
3 of 3
Last update:
‎09-14-2018 09:50 AM
Updated by:
 
Tags (1)
0 Kudos