cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Deepanshu.Grover
AppDynamics Team (Retired)

Symptoms

Server.log contains the following error message, while EUM metrics continue to be collected successfully:

 

com.singularity.ee.controller.beans.eumcloud.MetricsCountLimit|_ThreadID=2909754;_ThreadName=Thread-5;|Metric name "EUM|Browser|Chrome|Chrome 56|First Byte Time 80th percentile (ms)" matches but the limit of 100000 OTHER_WEB metrics has been reached for app 57 [count=118121]|#]

 

Diagnosis

This issue occurs when the property appdynamics.controller.eum.otherWeb.metricsCount.limit maximum has been reached.

 

Note: The com.singularity.ee.controller.beans.eumcloud.MetricsCountLimit is a shared limit for the total of distinct EUM metric names.

 

Solution

Change the "metric count limit" property to a higher value.

1. Login to the Controller: http://<controllerurl>/controller/admin.jsp;


2. Navigate to Controller Flags Servlet: http://<controllerurl>/controller/private/ControllerFlagsServlet

 

3. Edit the property appdynamics.controller.eum.otherWeb.metricsCount.limit value and click submit to save. 

 

The Controller will pick up the change.

 

 

Note: Before increasing the metrics count limit, try to manage all pages, AJAX, iFrames, and mobile request names using Custom Naming/Exclude rules. Be aware that deleting any pages, mobile requests, etc, will also delete the associated metrics (and metric names).

 

Additionally, increasing the metric count limit will increase disk utilization, which could lead to performance issues. The user assumes all risks.

 

Version history
Last update:
‎09-05-2018 04:23 PM
Updated by:
Join Us On December 10
Learn how Splunk and AppDynamics are redefining observability


Register Now!

Observe and Explore
Dive into our Community Blog for the Latest Insights and Updates!


Read the blog here