cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Knowledge Base

How do I resolve a Controller log full of error messages on v4.3?

In AppDynamics version 4.3, users saw the following warning messages appearing many times in the Controller server logs:

 

2017-08-24T10:20:48.026+0200|WARNING|glassfish 4.1|com.singularity.ee.controller.beans.cache.UiMetricDataCacheManagerImpl|_ThreadID=1422;_ThreadName=http-listener-1(233);_TimeMillis=1503562848026;_LevelValue=900;|UiMetricDataCacheManagerImpl: UiCacheMaximumCountOfOneMinuteRecurringTasks limit is hit.|#]

[#|2017-08-24T10:20:48.030+0200|WARNING|glassfish 4.1|com.singularity.ee.controller.beans.cache.UiMetricDataCacheManagerImpl|_ThreadID=1420;_ThreadName=http-listener-1(231);_TimeMillis=1503562848030;_LevelValue=900;|UiMetricDataCacheManagerImpl: UiCacheMaximumCountOfOneMinuteRecurringTasks limit is hit.|#]

 

To avoid filling the logs with this error message, set the logger level to SEVERE in the glassfish logger settings.

 

  1. Open the Glassfish UI in a browser using default port 4848.
    • http://localhost:4848/
  2. Open the logger settings and add the following logger property set to SEVERE.
    • logger.com.singularity.ee.controller.beans.cache.UiMetricDataCacheManagerImpl
  3. Save the new setting.

 

Note: This issue has been fixed in version 4.4.

 

 

 

Version history
Last update:
‎09-14-2018 01:04 PM
Updated by:
By replying you agree to the Terms and Conditions of the AppDynamics Community.
0 Kudos