NET (Agent, Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

httpclient| request had HTTP exception: Error in SSL handshake (Unknown error 336134278)

SOLVED
Highlighted
Creator

httpclient| request had HTTP exception: Error in SSL handshake (Unknown error 336134278)

Questions:

  1. what is the location of the "default cert file"?
  2. Is there a way in AppDynamicsConfig.json to disable cert validation?

 

To also note:

  1. I can curl to the http endpoints.
  2. I can verify the certificate using openssl.

 

OpenShift Console Log:

[Log files redacted]

 

^ Post edited by @Ryan.Paredez to remove log files. Please do not share or attach log files to community posts for security reasons.

httpclient| request had HTTP exception: Error in SSL handshake (Unknown error 336134278)
1 REPLY 1
Highlighted
Creator

Re: httpclient| request had HTTP exception: Error in SSL handshake (Unknown error 336134278)

I found a workaround for the moment:

 

ENV    SSL_CERT_FILE=/app/cacerts/ca_chain.pem