cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

NET (Agent, Installation)

Error message in log "could not connect to the controller"

jjchristline
Voyager

Error message in log "could not connect to the controller"

Hi,

 

I'm facing one issue in configuring .net application agent with controller after downloading it from wizard. 

 

I'm getting this error message

"Warn RegistrationChannel Could not connect to the controller/invalid response from controller, cannot get registration information"

 

 

Things I tried

1. telnet command failed

2. config.xml file are correct

 

Please suggest me on how to proceed further. 

By replying you agree to the Terms and Conditions of the AppDynamics Community.
Error message in log "could not connect to the controller"
5 REPLIES 5
Mohammed.Rayan
AppDynamics Team

jjchristine,

 

You need to have the connectivity between the controller and the agent in order for the registration to succeed and you have confirmed that the telnet failed,so please check internally if firewall or something in your network is not blocking the communication.

 

Hope this helps

 

Regards,

Mohammed Rayan

 

 



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Raunak.Mohanty
AppDynamics Team (Retired)

Hi ,

 

Since telnet is not working it could very well be the issue untill unless telnet is disabled at Controller server.

 

Can you confirm if you are able to open the Controller UI on the server where Agent is installed ?

Can you verify if you able to Test Controller Connection at AppDynamics Agent Configuration Tool ?

Are there any proxy configured on this server ?

 

Can you send the Agent logs located at C:\ProgramData\AppDynamics\

 

Thanks,

Raunak



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
jjchristline
Voyager

Hi,

 

First of all let me tell you that I'm using a Saas version only. 

I checked Controller connection in the agent configuration setup. 
please find the snapshot below. 

 

Raunak.Mohanty
AppDynamics Team (Retired)

Hi,

 

  Thanks that clarrifies why telnet does not work. Can you send me private message with logs folder attached ? This will help us investigate the issue

Can you confirm if you have <defaultProxy> element defined in web.config ?

 

Thanks,

Raunak



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
jjchristline
Voyager

Hi,



As discussed in the forum, may I know the web.config which you are
mentioning is same as config.xml?
which is available under "C:\Programdata\AppDynamics\DotNetAgent\Config"..
If that is so then the is not specified.

Please let me know how to proceed further.