Showing results for 
Show  only  | Search instead for 
Did you mean: 

AppDynamics not detecting standalone windows service


I am trying to register a standalone windows service as a separate tier / node to AppDynamics. So far in my dashboard it appears that the IIS services were detected, but the standalone has not.


I have confirmed that the standalone displays when running tasklist /m mscor*, and I have also restarted the coordinator service and standalone after updating the config.xml file.


Strangely, although the IIS services show in the controller dashboard, on using the Agent Configuration tool, I keep getting a 403 forbidden error when trying to test controller connection.


Are there steps I am missing? Do I need to put load on the standalone for it to be detected?


I currently see 2 databases and 5 nodes in my Controller UI, and there is a change in the number of calls between the last hour and the last 2 hours, so I believe that the IIS services are still reporting data.


I can access the Controller through Chrome and I am also able to reach it through telnet, but I still cannot with the Configuration Utility.

I was able to successfully connect my Standalone Application and Windows Service to the Controller. I'm still not entirely sure what the cause of the connectivity problems was, but I was able to get around it by filling in the Controller domain and port into the proxy options in the configuration.


Thank you for your help!


Are the nodes and IIS that are reporting on the same server as the one on
which standalone service runs?


Yes, they are hosted on the same server (Windows Server 2012 R2).


I believe I may be experiencing a similar issue and 1 of the warning in my agentLog specifically talks to an issue around a proxy.

Can you perhaps share how exactly you added the controler host and port into the proxy section?

Hi There


Also added the controller info as a proxy tag and the app server agent is now showing on the dashboard as up.


Thanks for the tip.

Its not the controller host and port that go in the proxy section but the proxy host and port if the connect needs to be made via proxy.


The following link should be helpful (Step 2)

I faced a similar issue recently. I think the problem is a bug in Extension Manager because it doesnt work well when need to connect via proxy without authentication. If you use proxy with authentication it works fine but when use proxy without authentication it throws the 401 error.