Showing results for 
Show  only  | Search instead for 
Did you mean: 

AppDynamics not detecting standalone windows service


I am trying to register a standalone windows service as a separate tier / node to AppDynamics. So far in my dashboard it appears that the IIS services were detected, but the standalone has not.


I have confirmed that the standalone displays when running tasklist /m mscor*, and I have also restarted the coordinator service and standalone after updating the config.xml file.


Strangely, although the IIS services show in the controller dashboard, on using the Agent Configuration tool, I keep getting a 403 forbidden error when trying to test controller connection.


Are there steps I am missing? Do I need to put load on the standalone for it to be detected?


AppDynamics Team (Retired)

Hi there,


The load could be the issue, have you tried that?


I did find this other thread that might help (with associated KB):






What exactly counts as load for a windows service? I have tried running the service several times as well as sending a message using it every couple of seconds, but it does not seem to register in the controller UI. Actually, the tier does not show up at all in the Tiers & Nodes tab.


Could you please post the section from your controller-info.xml where you configure the standalone services? (please mask any sensitive information) or maybe you tried configuring using the configuration utility as documented here,


Standalone services are not detected by default and you have to configure them.







By controller-info.xml, do you mean the config.xml file?


I've included these lines:


      <automatic />
<standalone-application executable="MyService.exe"> <tier name="Windows Service" /> </standalone-application> <standalone-application executable="E:\Program Files (x86)\...\MyService.exe"> <tier name="Standalone Tier 2" /> </standalone-application>

I have already tried using the configuration utility, but for some reason I kept getting a 403 forbidden error when trying to establish connection with the controller. Strangely, the IIS services are detected in the controller UI despite this.


Config looks good.

For how much time does the standalone service/exe run continously? Does it run for more than 2 or 3 minutes at a stretch?

If not, can you run a multiple times within a given minute and run for a few minutes?


Re: Connection refused error from the configuration utility does not make sense since IIS is already reported.

The standalone does not run continuously, but the Windows Service should be running continously, yet it is not registered in the controller either. I tried putting some load on it, with the process memory usage increasing around 20 mb, but nothing seems to be reflected in the controller.


One additional note, although I have defined the Windows Service and Standalone tiers in my config file, I do not see them listed as tiers in the Tiers & Nodes tab. Does this mean that the controller may not have received the updated config file?


For Windows Service also, you have to give the full path to the exe in your config file.


Also, i assume for the standalone service, you have masked the path when you copied it here but have the full actual path in your configuration?


If the same server is reporting for IIS, then you wont see the tier getting registered without any traffic being detected.

I changed the Windows Service executable to the full path. I still can't seem to connect to the controller.


In AgentLog.txt, I am getting this error on searching for the windows service:


Could not connect to the controller/invalid response from controller, cannot get initialization information, controller host [...], port[80..], exception [System.Net.WebException: The remote server returned an error: (403) Forbidden.

Are you sure your IIS sites are still reporting and collecting data? and its from the same server?

I would fix that issue first (connectivity) before checking the standalone services.