Showing results for 
Show  only  | Search instead for 
Did you mean: 

Setting up machine agents

New Poster



I am not following how to set up a machine agent. 


I log into the AppDynamics console and click on "Servers" - the message that I don't have any servers appears.


I select "Get Started", select Linux from the drop-down, leaving the default controller URL, and I download the agent. I secure copy (SCP) the zip file to our Amazon EC2 server.


I create a subdirectory in /home/ec2-user called machine-agent, and unzip ~/ into it. 


In that directory, I run:



jre/bin/java -jar machineagent.jar


which produces the following output:


(dev)[ec2-user@our-server machine-agent]$ jre/bin/java -jar machineagent.jar
Using Java Version [1.8.0_162] for Agent
Using Agent Version [Machine Agent v4.5.9.2096 GA compatible with Build Date 2019-03-19 19:13:12]
[INFO] Agent logging directory set to: [/home/ec2-user/machine-agent]
ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console


and click "Continue" back on the servers page where I downloaded the zip file.


I tried passing




to the java command, but the log4j2 error still persists. 


No further output is generated by the machine agent. It just sits there. On the page that has the list of servers, the server shows up, but nothing is reported for disk space, CPU %, memory %, - all fields are blank. At the bottom of the page it says "None of these Servers have Server Visibility Enabled" - but from what I have read from other thread posts, there should still be basic information about the server showing up in the dashboard. 


I click on settings, "App Dynamics Agents", and the "Machine Agents" tab, the machine agent shows up and is listed as enabled. Double-clicking on this row shows:



Name	ourhostname.ourdomain
IP Address	ourhostname.ourdomain
OS	Linux
Install Time	05/22/19 6:57 PM
Last Start Time	05/22/19 7:14 PM


The status never changes from initializing. 


Under the Applications column, it says: "(not associated with any applications)", but when I click "Enable" and move our application to "Selected Applications (1)", and press OK, nothing changes. The row remains as "(not associated with any applications)". 


Are there incoming ports that have to be opened up to allow access to the machine agent? If so, wouldn't that defeat the purpose of having an agent running on the server itself? 


Server Summary


Advanced features will be available with Server Visibility license
Your machine agent is running in basic machine monitoring mode. 
You can view basic hardware metrics in Applications - Tiers & Nodes - Node Details - Server.
Learn More  about advanced server monitoring: Properties
AppDynamics|Agent|Build Number
AppDynamics|Machine Type
AppDynamics|Agent|Machine Info|os.arch=amd64|os.version=4.14.114-83.126.amzn1.x86_64
AppDynamics|Agent|Agent version
Machine Agent v4.5.9.2096 GA compatible with Build Date 2019-03-19 19:13:12
AppDynamics|Agent|Install Directory
AppDynamics|Agent|JVM Info HotSpot(TM) 64-Bit Server VM|java.vendor=Oracle Corporation|java.version=1.8.0_162|user.language=en||user.variant=unknown


Any suggestions?


Someone recommended trying machine agent version 4.4 - how do you download that? From the Getting Started page, I don't see any option to download a previous version. 



  I have the same problem, I also read the parameter and download version 4.4
  I downloaded it from here:


I'm trying it, 

I hope you help them,