Showing results for 
Show  only  | Search instead for 
Did you mean: 

domain1 error when starting Appdynamics


I am running into an error when installing Appdynamics. I'm installing Appdynamics on an ec2 instance that I provisioned (let's say with IP I'm using ansible to install appdynamics inside the ec2; however, I run into an error in one of the tasks so I try to manually install appdynamics inside the ec2 instance. 


The error seems to occur when when my tries to write to the response.varfile. When I run the following command:


$ sudo ./ –q –varfile


I get this error:

Following values are not specified: mysqlRootUserPassword, rootUserPassword, password. Please add them in the response.varfile and retry the installation.

I check my response.varfile and I see that a mysqlRootUserPassword, rootUserPassword, and password are all defined so I'm confused as to why I am getting this error in the first place.

Anyways, I then try the install again except this time I don't do a silent install:

$ sudo ./ –varfile

Everything seems to be working fine until I get the following timeout error:

Failed to start the Controller in the timeout period of 45 minutes.
If you are able to start the Controller manually, try re-installing the Controller after increasing the timeout.
If unable to start the Controller, contact AppDynamics support for assistance.

I check startAS.log and find this:

Waiting for domain1 to start .Command start-domain failed.

My etc/hosts/ has the following domains (purposely hidden):

172.20.0.##1 host.1
172.20.0.##2 host.2
172.20.0.##3 host.3
172.20.0.##4 host.4

I'm not sure why my installation isn't working but I'm guessing it has something to do with the IP not being associated with a hostname. Not sure, but any help with this will be much appreciated!




Hi Jahinippa,


Couple of things here

- Is the IP / hostname provided during the install (in your case in response.var file) same as the ec2 instance dns name or IP?

- I would also check if there is anything else running on the ec2 instance on the default http port that appdynamics uses (port 8090), netstat command is your friend here.

- I would just clean up everything and do a fresh install with user input, i.e.

sudo ./




AppDynamics Team

Hi Jahinnipa,


Yes, the issue could as well be with not having full qualified host names configured.


Please refer the section "Amazon AWS and Microsoft Azure notes" in the following documentation:


Install the Controller - Version 4.2.x


Please share the following logs so that we can identify the root cause of this issue controller not starting.


Please run the following command.


<ControllerHome>/bin/ zip-logs


This would create a zip file called Please upload the attachment here.

Regarding the installation issues, please share the files in the folder:




Please note the above folder is a hidden folder starting with a "."