cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to enable health rule using curl command

Chandan.Gupta
Creator

curl -X PUT -d "enabled"=true --user usernme@account:password https://[Redacted].saas.appdynamics.com/controller/alerting/rest/v1/applications/Application-ID/health-rules/HealthRule-ID/ 

 

I am using this command to enable the health rule but no change is reflecting on Saas controller. 

 

^ Edited by @Ryan.Paredez to remove Controller URL. Please do not share your Controller URL on Community posts for security and privacy reasons.

1 REPLY 1

Mario.Morelli
Architect

Hi Chandan

 

You can use the below, should give you what you require

 

curl --user user@account:password -X PUT -H "Content-Type: application/json" -d '{"enabled":"true"}' https://<AppD FQDN>/controller/alerting/rest/v1/applications/<application-id>/health-rules/<healthrule-id>/configuration

 

Ciao



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Learn more about me in the Community Member Spotlight Q & A