Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trouble accessing controller API

New Poster

Hi All


Apologises if I've missed something obvious but I've been having some difficulties accessing my hosted controller's API. I want to collect metric data programmatically and have been using Chrome's Postman extension to try and query my controller's API. I've been trying to access it using the following:


URL: https://<MyControllersName>


user: <username>@<accountname>:<accountpassword>


However I keep getting a 401 Unauthorized response back from this. I have also tried the following as suggested here: 


URL: https://<MyControllersName>


Account: <MyAccountName>

Username: <Username>

Password: <AccountPassword>


To add a bit more context I am using the pro free trial. I have tried both my AppDynamics login name and my controller username for authentication which has both failed. The password I am using is my AppDynamics account password. I have found that controllers also have passwords however when following the instructions here: ... am unable to get to the admin console as appending /admin.jsp to my controller's URL just timesout. As a result I've been using my AppDynamics log in account password instead. 


Any help would be greatly appreciated


AppDynamics Team



You need to provide the controller password which you use to login into the controller UI. Make sure you pass the correct credentials as controller's username and password and having enough access to use the api. 


Also, as per your controller url, we assume that it is a saas controller. Saas controller's admin.jsp page access is not available for customers whose controller is saas hosted. This is for on-prem customers. Let us know if you are using saas or on-prem.


Please refer below for more information

Provide the relevant screenshots in case you still face an issue.




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Thanks, that was my issue I was providing the wrong password!