Showing results for 
Show  only  | Search instead for 
Did you mean: 

IIS Nodes and BTs Not Registered




I have installed and configured .NET agent v4.4.1, at first the installation fails because there are need for Universal C Runtime (

After the Windows Update and C Runtime installed, the Agent succesuly installed. I have done the configuration and restart the IIS, and can see the Machine Agent tier is registered. Today the application is supposed to be hit by many users (it's in production env), but when i check it the dashboard, there are nothing. No BT, no IIS application Nodes, just Machine Agent tier only. I check the logs, and there was no errors at all.

I decided to downgrade the Agent to v4.3.8.5, install, configure, and restart IIS without any problems. I hit the application many many times, but the result is still the same, no BTs and only have Machine Agent tier.

The Agent Logs doesn't have any error, and the Controller logs have an error but i doubt it has something to do with this.

[#|2018-02-22T21:39:24.890+0700|WARNING|glassfish 4.1||_ThreadID=51;_ThreadName=http-listener-1(7);_TimeMillis=1519310364890;_LevelValue=900;|Accepting validation error for compatibility reasons Cannot find a custom match point definition for BT tiers/list/.POST, component id 6, component name App Server, application id 4, application name AppDynamics Controller

In the event viewer, there is an info message saying AppDynamics.AgentProfiler requested not to load profiler (see attached event-02.jpg).

I also attached the controller logs, agent logs, and some screenshots. Please advice.



Couple of things:

- Did you do a full IIS Reset after the installation?

- How have you configured the IIS site in the config.xml? You used the configure utility and then configure the site/ app pool?

- is there any other profiler running on the system?


One way to check if to open process explorer on the server, look for the running process related to your iis site / app pool and check for COR_PROFILER entry?



- Yes, i did IIS full restart

- I use the configuration utility to configure the IIS and do the restart. Below is my configuration file content:

<?xml version="1.0" encoding="utf-8"?>
<appdynamics-agent xmlns:xsd="" xmlns:xsi="">
  <controller host="" port="8090" ssl="false" enable_tls12="false">
    <application name="LMS-PROD" />
    <account name="customer1" password="6e16a57d-5394-4318-9a0a-c6663a5b6db3" />
  <machine-agent />
        <application path="/FUSE" site="Default Web Site">
          <tier name="APP-FUSE" />
        <application path="/LMSCONSUMER" site="Default Web Site">
          <tier name="APP-LMSCONSUMER" />

- No that i'm aware of. But will double check the profiler tonight.

AppDynamics Team (Retired)

Hi Tommy,


  I have attached a screenshot of Process Explorer on how you can verify this. In case you do not see Profiler and Agent dlls getting loaded into the Process, it most likely is the Permission issue.

Identify the accounts under which the worker processes are running and provide these accounts read and write permission on Agent installation and Logs directory and then recycle Agent Coordinator service, IIS and generate load.




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.



You're right, there was another profiler loaded into w3wp.exe.


One more thing, our prospect have an application built on .NET and installed it as Windows Service, but not listed under command tasklist /m "mscor*", what is possibly the reason? Is there any workarround to monitor this application?

AppDynamics Team (Retired)

Hi Hendra,


 TaskList command many a time does not show correct output. Best option is to use Process Explorer and verify if mscorlib/clr dlls are loaded. You can also check if usual .Net assemblies are loaded ( System.*)


If you are sure this is .net based Windows Service please use the following document to set up instrumentation





Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.