Latest Release

cancel
Showing results for 
Search instead for 
Did you mean: 

Android appdynamics-gradle-plugin broke between 4.4.0.440 and 4.4.1.589

Highlighted

Android appdynamics-gradle-plugin broke between 4.4.0.440 and 4.4.1.589

The gradle plugin now requires the temp 'build' directory otherwise all gradle tasks fail. 4.4.0.440 does not have the problem but the latest release 4.4.1.589 even fails on a ./gradlew clean (if you don't have a temp build directory, so run it twice if it works the first time) with the following: 

 

java.io.FileNotFoundException: /YourCode/YourAppModule/build/appdynamics_eum_android_bci.log (No such file or directory)

 

 

Caused by: java.lang.RuntimeException: java.io.FileNotFoundException: /YourCode/YourAppModule/build/appdynamics_eum_android_bci.log (No such file or directory)

        at com.appdynamics.android.logging.BCILogger$MultiLogger.log(BCILogger.java:130)

        at com.appdynamics.android.logging.BCILogger$1.log(BCILogger.java:41)

        at com.appdynamics.android.logging.BCILogger.log(BCILogger.java:53)

        at com.appdynamics.android.logging.BCILogger.debug(BCILogger.java:76)

        at com.appdynamics.android.gradle.DependencyInjector$1.afterEvaluate(DependencyInjector.groovy:54)

        at org.gradle.internal.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)

 

Android appdynamics-gradle-plugin broke between 4.4.0.440 and 4.4.1.589
5 REPLIES 5
AppDynamics Team

Re: Android appdynamics-gradle-plugin broke between 4.4.0.440 and 4.4.1.589

HI Mathew,

 

DO you have a sample project that you can share?

OR

Can you attach the full log, gradles (module/app) files?

 

Regards,

Gaurav



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Creator

Re: Android appdynamics-gradle-plugin broke between 4.4.0.440 and 4.4.1.589

Have Same problem ...
i m using
classpath 'com.appdynamics:appdynamics-gradle-plugin:4.4.+'
And
implementation 'com.appdynamics:appdynamics-runtime:4.4.+'

Creator

Re: Android appdynamics-gradle-plugin broke between 4.4.0.440 and 4.4.1.589

at com.android.build.gradle.internal.pipeline.TransformTask$2.call(TransformTask.java:217) at com.android.builder.profile.ThreadRecorder.record(ThreadRecorder.java:102) at com.android.build.gradle.internal.pipeline.TransformTask.transform(TransformTask.java:212) at sun.reflect.GeneratedMethodAccessor537.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.gradle.internal.reflect.JavaMethod.invoke(JavaMethod.java:73) at org.gradle.api.internal.project.taskfactory.IncrementalTaskAction.doExecute(IncrementalTaskAction.java:46) at org.gradle.api.internal.project.taskfactory.StandardTaskAction.execute(StandardTaskAction.java:39) at org.gradle.api.internal.project.taskfactory.StandardTaskAction.execute(StandardTaskAction.java:26) at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter$1.run(ExecuteActionsTaskExecuter.java:121) at org.gradle.internal.progress.DefaultBuildOperationExecutor$RunnableBuildOperationWorker.execute(DefaultBuildOperationExecutor.java:336) at org.gradle.internal.progress.DefaultBuildOperationExecutor$RunnableBuildOperationWorker.execute(DefaultBuildOperationExecutor.java:328) at org.gradle.internal.progress.DefaultBuildOperationExecutor.execute(DefaultBuildOperationExecutor.java:199) at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:110) at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeAction(ExecuteActionsTaskExecuter.java:110) at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:92) ... 32 more Caused by: java.io.FileNotFoundException: ***************app/build/appdynamics_eum_android_bci.log (No such file or directory) at java.io.FileOutputStream.open0(Native Method) at java.io.FileOutputStream.open(FileOutputStream.java:270) at java.io.FileOutputStream.(FileOutputStream.java:213) at com.appdynamics.android.logging.BCILogger$MultiLogger.error(BCILogger.java:143)

Creator

Re: Android appdynamics-gradle-plugin broke between 4.4.0.440 and 4.4.1.589 - RESOLVED

Resolved for now , just copy paste in app gradle : 

 

adeum {
enabledForDebugBuilds = false
}

 

Explorer

Re: Android appdynamics-gradle-plugin broke between 4.4.0.440 and 4.4.1.589

Still a problem in:

 

'com.appdynamics:appdynamics-gradle-plugin:4.4.3.928'