Showing results for 
Show  only  | Search instead for 
Did you mean: 

AppDynamics Enterprise Console Installation on Windows

New Member

During installation I am receiving two error messages, one immediately after the other. The first states


Internal error: Could not read from D:\applications\appdynamics\Platform\installer\jre\bin\server\classes.jsa


This message is then immediately followed by


Failed to copy jre into platform-admin directory


I am installing on a windows system. This sounds like either a file path issue, where a copy of Java can not be found on my system or a file permissions issue. I have tried many of my usual solutions to these types of problems but none of them have worked.


AppDynamics Team

Hello John,


It could be a permissions issue, but since the installer is trying to install a JRE that is a part of the product from the installation package, it should not be an issue with a copy of Java already on your system.


I am not sure what the "usual solutions" you tried are, but here are the ones that I can think of:
1. Are you running the installer as Administrator?
2. Does the file D:\applications\appdynamics\Platform\installer\jre\bin\server\classes.jsa exist and if so, what permissions do you have on it? If the file does not exist, what folders in the path exist?
3. Are there any other errors in the install log, especially preceding this one?
4. Have you tried re-downloading the installer and reinstalling, in case the installer package was somehow corrupted?


For reference, here is the document on EC installation: