cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

NET (Agent, Installation)

New .NET Agent Install Causing TLS Errors and Application Issues

Aaron.Kjos
Creator

New .NET Agent Install Causing TLS Errors and Application Issues

Hi,

I created a new application for AppD for my system's UAT environment. These are Windows Server 2019 IIS web and application servers with the .NET agent.

 

After installing the AppD .NET agent and having it running, it does report back to the controller, but we observed new errors in our application and the business process we are trying to run is failing with this:

 

Full Error Message: System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.

 

If I disable AppD, then the process works and the TLS error goes away.   So AppD is actually causing an impact on our environment. Any ideas on how I can fix it?

Tags (1)
By replying you agree to the Terms and Conditions of the AppDynamics Community.
New .NET Agent Install Causing TLS Errors and Application Issues
3 REPLIES 3
Ryan.Paredez
Community Manager

Hi @Aaron.Kjos,

 

I found this info. I'm not sure if this totally matches up with what you are looking for. But let me know if it helps or at least helps you tackle the problem in a different way.

 

1) Navigate to C:\ProgramData\AppDynamics\DotNetAgent\Config
2) Open config.xml
3) At <controller> tag add enable_tls12="false" as an attribute.

<controller host="<HOST>" port="<PORT>" ssl="<false or true>" enable_tls12="false">

4) Save the file
5) Restart the "AppDynamics Agent Coordinator" service at services.msc
6) Restart the IIS


Thanks,
Ryan, AppDynamics Community Manager



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Aaron.Kjos
Creator

Ryan, thank you.


I think adding this enable_tls12="true" to the agent config.xml may actually be what I needed.

I'm testing that solution now.

 

Thanks!

Ryan.Paredez
Community Manager

Hi @Aaron.Kjos,

 

Follow up and let me know after your testing!

 


Thanks,
Ryan, AppDynamics Community Manager



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.