Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error opening zip file or JAR manifest missing




I get the error


2017-02-28T15:40:47.800889709Z Error opening zip file or JAR manifest missing : /path/to/agent/appdynamics/appserveragent/javaagent.jar
2017-02-28T15:40:47.801251415Z Error occurred during initialization of VM
2017-02-28T15:40:47.801278670Z agent library failed to init: instrument


if I am trying to start my Application from within a Docker container with


docker start appname


If I start the application without Docker everything works find, so the path is correct and the agent is working.

Can anyone help me?






Hi Michael,


Just to make sure, you have the java agent.jar present in the path that you are giving in the configuration, right?

Also have you tried doing ls /path to the file/jar with the same user id with which you start the application and see if its accessible?



Hi gurmit.arora,


of course the javaagent.jar is accesible and the folder it resides in and the file itself is owned by the user who executes it.

So if I run 

/usr/bin/java -javaagent:/path/to/agent/javaagent.jar -jar /path/to/app/appname.jar

everything works fine as I said earlier.


But now with Docker:

If I build the Docker File everything is ok but if I start the container via

docker start appname

I get the error

Error opening zip file or JAR manifest missing : /path/to/agent/javaagent.jar
Error occurred during initialization of VM
agent library failed to init: instrument

My problem is, my Docker Knowhow is limited at the moment. It it possible, that the are some issues with the ownership of the agent if I start it with Docker, but unfortunately I have no idea what I have to change.

AppDynamics Team (Retired)

@michael.lossagkand @gurmit.arora I spoke with our product manager, and he wrote:


"I think the customer is trying to use APM with Alpine Linux. There may be issues with libc compatibility."


Can you let us know if you are using APM with Alpine Linux?



New Member

I have the same porblem. Have you resolved it?

Hi I face the same issue and it is resolved after changing the folder permission where the jar is present.


chmod -R o+x <folder where the jar is present>


Hi Michael,


Have you found a resolution to this? I have the same problem and i am sure i had set the permissions as expected. Any other ideas? I am running on CentOS with OpenJDK 1.8




I simply forgot to mount the folder into docker respectively the mounted folder was wrong, thats it