cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Java (Java Agent, Installation, JVM, and Controller Installation)

Changed SQL Capture to Capture Raw SQL now getting Max SQL Capture Length [999] Reached

SOLVED
craig.sanborn
New Poster

Changed SQL Capture to Capture Raw SQL now getting Max SQL Capture Length [999] Reached

Just recently changed SQL Capture settings from Filter Parameter Values to Capture Raw SQL.  

 

Parameter values are now displaying fine, however, longer sql queries are now being truncated to 999 characters and seeing "Max SQL Capture Length [999] Reached" at the end of the SQL.  They weren't previously being truncated before changing the setting.

 

Can someone let me know which setting/configuration controls this 999 limit?  Google and searches on this site haven't turned up anything.

 

Thanks,

Craig

By replying you agree to the Terms and Conditions of the AppDynamics Community.
Changed SQL Capture to Capture Raw SQL now getting Max SQL Capture Length [999] Reached
3 REPLIES 3
Cody.Naumann
AppDynamics Team

Hi Craig,

 

I found this post which I think has the solution at the bottom. Let me know if that works for you:

 

https://community.appdynamics.com/t5/Archive-AppDynamics-Discussions/Increase-the-size-of-the-Detail...

 

Cody

craig.sanborn
New Poster

Thanks Cody,

 

I had also seen that post but was a little apprenhensive about adding a custom configuration and a new property - but after your post I bit the bullet and it did indeed work.  Adding new agent property max-length-batch-sql to custom node configuration as Integer(5000) in my case worked great.

 

Thanks,

Craig

Cody.Naumann
AppDynamics Team

Cool! Glad I was able to find that for you.

 

Cody