Java (Java Agent, Installation, JVM, and Controller Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

Appdynamics not showing pojo transactions

Highlighted

Appdynamics not showing pojo transactions

Hi,
We have configured some pojo to monitor but appdynamics not showing anything under business transactions with that pojo.
What could be the issue?
Thanks!
Appdynamics not showing pojo transactions
6 REPLIES 6
Highlighted
Moderator

Re: Appdynamics not showing pojo transactions

What context is the POJO you configured in?  If it is downstream of another entry point (for example, if it's called within a servlet) then you will need an exclude rule to prevent the out of the box servlet rule from naming the transaction before your rule gets hit.

 

Warm regards,

Peter

 

 



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
AppDynamics Team

Re: Appdynamics not showing pojo transactions

Hi,

 

Could you please share screenshot of the pojo configuration rule and agent log with us to debug it further.

 

Thanks,

Atyuha



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted

Re: Appdynamics not showing pojo transactions

pojo.JPGThis is how the pojo configuration looks like.Its not showing anywhere in the business transactions.

Highlighted

Re: Appdynamics not showing pojo transactions

I dont know what do you mean. But I have already named the Pojo that I want to see in business transactions. And even if it has been named by any other transaction, the method should be shown under that transaction which is not showing.

Highlighted

Re: Appdynamics not showing pojo transactions

I also tried with fully qualified class name but still it doesn't show anything under business transactions.

Highlighted
AppDynamics Team

Re: Appdynamics not showing pojo transactions

Hi,

 

Please provide fully qualified class name and change the class name / method name "equals" to "contains" and check if  the check box for pojo monitoring is checked. Please make sure you have enough load on the application. please share the agent log to debug the issue.

 

Thanks,

Atyuha



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.