cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

NET (Agent, Installation)

Problems .net 5 WebAPI unable to instrument using .NET Core for Linux SDK

SOLVED

Problems .net 5 WebAPI unable to instrument using .NET Core for Linux SDK

Hello, I have a net 5 WebAPI deployed in a docker linux container. I want to instrument the application in AppDynamics. The application works and I test it everytime with swagger

I've tried 2 implementations

  1. Install the .NET Core Microservices Agent for Windows -> https://docs.appdynamics.com/4.5.x/en/application-monitoring/install-app-server-agents/net-agent/net...
  2. .NET Core for Linux SDK -> https://docs.appdynamics.com/21.5/en/application-monitoring/install-app-server-agents/net-agent/net-...

The first scenario didn't work for me I got a consistent error, a single log line saying "use clr profiler", 

The second does nothing at all I have no feedback what so ever and no log is created

This is my Docker configuration

"Docker": {
"commandName": "Docker",
"launchBrowser": true,
"launchUrl": "{Scheme}://{ServiceHost}:{ServicePort}/Swagger",
"environmentVariables": {
"CORECLR_PROFILER": "{57e1aa68-2229-41aa-9931-a6e93bbc64d8}",
"CORECLR_ENABLE_PROFILING": "1",
"CORECLR_PROFILER_PATH": "/app/bin/Debug/net5.0/runtimes/linux-64/native/libappdprofiler.so",
"APPDYNAMICS_LOG_PATH": "/app/bin/Debug/net5.0"
},
"publishAllPorts": true,
"useSSL": true
}

 

And this is the app dynamics configuration
{
"feature": [
"FULL_AGENT"
],
"controller": {
"host": "MYHOST.saas.appdynamics.com",
"port": 443,
"account": "myAccount",
"password": "mypassword",
"ssl": true,
"enable_tls12": true
},
"application": {
"name": "myapplicationname",
"tier": "my-appliation-tier",
"node": ""
},
"log": {
"directory": "/app/bin/Debug/net5.0",
"level": "ALL"
}
}

By replying you agree to the Terms and Conditions of the AppDynamics Community.
Problems .net 5 WebAPI unable to instrument using .NET Core for Linux SDK
11 REPLIES 11

I had some progress but now I get the following in the container log

appd.agent.profiler(Info): Successfully locate config file from /app/bin/Debug/net5.0/MyProject.AppDynamicsConfig.json
appd.agent.profiler(Warn): Failed to verify loaded config : node nameconfig file entry or environment variable APPDYNAMICS_AGENT_NODE_NAME is empty
appd.agent.profiler(Warn): Failed to load configuration, profiler will not attach.
appd.agent.profiler(Warn): Profiler initialization failed and .NET Agent is disabled.

Sarabjit.Tatra
AppDynamics Team

@Maximiliano.Guillen - You need to specify node name as its missing in you JSON using "node": "" tag or setting APPDYNAMICS_AGENT_NODE_NAME environment variable.