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Deepanshu.Grover
AppDynamics Team (Retired)

Symptoms

When trying to create a new analytics search the dashboard or ui becomes white even when analytics licence is correct.

 

This issue is seen when Analytics is enabled for the first time and there is some configuration issue due to which the desired analytics data is not seen.

 

Diagnosis

When checked inside the analytics-agent.log following message is seen:

analytics-agent / Connection to [http://<events-service-host>:<events-service-port>/v1]: (unhealthy) The supplied auth information is incorrect or not authorized.

 

When checked inside server.log following message is seen:

com.singularity.ee.controller.ui.services.analytics.AAnalyticsUiService|_ThreadID=83;_ThreadName=Thread-5;|Could not find account [Global_account_name] via lookup

 

Events Service logs report healthy.

 

Please collect related components logs as mentioned above, i.e. events service, controller server.log and analytics-agent.log.

 

Once the logs are collected, please try to isolate the issue, for example in this particular case it was due to wrong auth information being used between components.

 

Solution

To resolve this issue, please verify the auth info being passed by following below steps:

 

1) Inside analytics-agent.properties file, please modify the following property to the provided value:
http.event.endpoint=http://<events-service-host>:<events-service-port>

2) Verify that the http.event.accessKey is correct from the License page account access key value.

 

3) As with Analytics its recommended to use the standalone events service, so make sure that the following key values should match:

   a) ad.accountmanager.key.controller inside events-service-api-store.properties.

   b) appdynamics.analytics.server.store.key inside controller administrator console(admin.jsp).

 

4) Verify that the value for appdynamics.analytics.server.store.url inside controller administrator console should point to exact events service:

http://<events-service-host>:<events-service-port>

 

Controller Settings - AppDynamics.png

 

Once all the above configuration is modified, please make a restart of events service and analytics agent to bring the above config changes into effect.

 

After that when everything will be up and running the issue should not be seen anymore.

Version history
Last update:
‎11-30-2018 05:30 PM
Updated by: