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Deepanshu.Grover
AppDynamics Team (Retired)

Symptoms

On restarting the Events Service Cluster with the platform admin it fails with following error:

 

./bin/platform-admin.sh restart-events-service 
Restarting events service cluster. Please wait, as this operation may take some time.
Events Service restart failed. Disable Transient Rebalancing failed

 

Diagnosis

This issue occurs during the restart of the Events Service using platform admin only. When we tried restarting it manually using the following command, it startws  succesfully when stopped.

nohup ./bin/events-service.sh start -p ./conf/events-service-api-store.properties &

 

When tried to telnet or ping from the Controller machine to the Events Service machine, it's not going through:

 

 curl http://<events_service_host>:9080/_ping 
curl: (7) couldn't connect to host

telnet <events_service_host> 9080
Trying <events_service_host>...
telnet: connect to address <events_service_host>: No route to host

 

This occurs when there is any firewall blocking the connection in between.

 

Solution

Conclusion of this issue is that the OS Firewall blocks the connection made by the platform_admin during the installation step. 

 

To resolve the issue, disable the OS Linux Firewall, then uninstall and re-install the Events Service again using platform admin.

 

Once this is done, the Events Service process sjpi;d run properly and you should be able to restart the Events Service process from the Controller with platform_admin command.

Comments

Hi @Deepanshu.Grover 

I did the above and still having the same issue in the installation,

the error is port 9080 is not pingable even I tried different ways to open make it listening but still the same issue,

 

* I tried with opened and stopped firewall 

 

here is my thread https://community.appdynamics.com/t5/Business-iQ-Analytics/Starting-Events-Service-cluster/m-p/44162... 

 

Claudia.Landivar
Community Manager

Hello, @Abdulrahman.Kazamel 

 

I've done some checking and the advice is that you open a Support ticket. The team will need to get more specific information from you, best handled in that context.

 

I hope this helps!

Claudia Landivar

Community Manager & Editor

Version history
Last update:
‎11-30-2018 01:43 PM
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