NET (Agent, Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

Tier1 (standalone Remoting service) to Tier2 (standalone Remoting service) communication

Highlighted
Wanderer

Tier1 (standalone Remoting service) to Tier2 (standalone Remoting service) communication

Hi,

Ive a producer service Tier1 which is the entry point to my application (from extrernal systems) - which calls a remoted service Tier2. Both these are .Net applications (.Net standalone exes) on separate machines.

These show up correctly in the flowmap (attached - Red is Tier1, Yellow Tier2).

 

Ive a CustomRule set for Tier1 - with the ClassName and MethodName set - and AppD detects these transactions.

Also Ive a CustomRule set for Tier2 - with ClassName and MethodName set - which is the entry point to this tier from tier1.

 

When Im checking the snapshots for Tier1 - the transaction shows the Potential Issue as the remotedcalled as the longtest running (Tier1 Shows the Remoted Call.png).When "Drill Down to Call Graph" on this - just gives the call graph till the remoted call only but I expected the Tier2 method call stack to be shown along with the Tier1 call graph (with the timing splitup etc. Pls check remotedcall.png.) Is this possible ie from Tier1 Transaction - would I see Tier2 entry point and the method call graph (along with times). I searched documents - found the article "Configure Custom Correlation for .NET Applications" 

Is this how I need to set up the config.xml for both the .NetAgents so that I can see the remotecall graphs as well. Please suggest.

Tier1 (standalone Remoting service) to Tier2 (standalone Remoting service) communication
1 REPLY
Employee

Re: Tier1 (standalone Remoting service) to Tier2 (standalone Remoting service) communication

Hi Mohak -

 

Thank you for the detailed description.  Instead of going down the custom correlation path (which is a fairly complex process)... have you followed the steps outlined in the documentation to Enable Correlation for .NET Remoting?  That is not enabled by default and seems to be what you are trying to accomplish.