NET (Agent, Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

.Net core agent Linux is not connecting to the saas controller

Explorer

.Net core agent Linux is not connecting to the saas controller

I have downloaded AppDynamics-DotNetCore-linux-x64-4.5.17.0.zip and extracted binaries from zip folder and copied them to the /opt/appdynamics/dotnet. (libappdprofiler.so,AppDynamics.Agent.netstandard.dll and AppDynamicsConfig.json)And edited AppDynamicsConfig.json with contoller and application details And also setted required environmental variables .Created a sample .net core razor application using .NET core 3.0 and running it using kestrel service configuration.


How can we know whether agent is connected to controller or not?
Observed that 11449_agent_0.log generated in /tmp/appd/dotnet and there is no errors in the log.
After starting agent sucessfully there are three warnings in agent log.


2019-12-10 17:06:14.330299| WARN|httpclient| Invalid header in Http response
2019-12-10 17:06:14.330434| WARN|agent| Agent config request error {http status 401}
2019-12-10 11:15:15.107991| WARN|agent| Connection back off limitation in effect for config request


but there is no metrics in the controller.

 

We use the following versions,


AppDynamics Agent 4.5.17.0
AppDynamics Controller build 4.5.13.3067 (appdynamics saas controller)
Linux centos7
.NET Core 3.0

 

Note: I did not change the project code as specified in the link https://docs.appdynamics.com/display/PRO45/.NET+Core+for+Linux+SDK. Will it work out of the box..?

 

.Net core agent Linux is not connecting to the saas controller
1 REPLY 1
Architect

Re: .Net core agent Linux is not connecting to the saas controller

If it's complaining about HTTP then there there might be an issue with your AppDynamicsConfig.json. Can you vi back into it and make sure you set it to point to the Controller correctly?

 

This doc may help: https://docs.appdynamics.com/display/PRO45/.NET+Agent+for+Linux+Advanced+Configuration+Options

 

Pay special attention to the ports you're using also to make sure they're not blocked, and that you're using the correct ones whether you're using SSL or not. Another place to check would be the cert trust.





Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.