NET (Agent, Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

.NET Agent

Highlighted
Producer

Hi,

 

I'm trying to configure the .NET Agent for a Windows Service that launches and EXE that makes HTTP requests. 

 

The machine agent appears in the controller, but the App Agent version is null and runtime is null and despite setting up Class/Method in buisness transactions nothing seems to show.

 

We are using .NET 4.5.

 

It seems the config matches because I get this in the log

AppPools:
Console:
qtagent.exe AppDomain:*
qtagent_40.exe AppDomain:*
qtagentservice.exe AppDomain:*
Services:

 

Any help would be much appreciated. Many thanks

 

Here's my config

<machine-agent />
<app-agents>
<IIS>
<applications />
</IIS>
<standalone-applications>
<standalone-application executable="QTAgent.exe">
<tier name="Load Test Agent Tier" />
</standalone-application>
<standalone-application executable="QTAgent_40.exe">
<tier name="Load Test Agent Tier" />
</standalone-application>
<standalone-application executable="QTAgentService.exe">
<tier name="Load Test Agent Tier" />
</standalone-application>
</standalone-applications>
</app-agents>
</appdynamics-agent>

.NET Agent
6 REPLIES 6
Highlighted

Try to specify the full path to the exe-files.

Highlighted
Producer

Thanks, I tried that but no luck.

 

I can see that the exe with the class I'm monitoring isn't appearing but one of the other exes is...

Highlighted
AppDynamics Team (Retired)

Hi Robert,

 

The Class/Method business transaction requires full class name including namespace to be specified. Did you do that?

 

Otherwise if you zip up %ProgramData%\AppDynamics\DotNetAgent\Logs and attach it here, we can help troubleshoot.

Highlighted
Producer
Hi Ryan,

I haven't tried that, the example I saw didn't have one. I'll give that a try tomorrow, many thanks.

Rob
Producer

Hi Ryan,

 

I've added the namespace but I've noticed it appears only one of the executables is being shown on the AppDynamics controller and it's one that doesn't have the class.

 

I've tried to attach zip but I get this message:

  • The file logs.zip does not have a valid extension for an attachment and has been removed. jpg,gif,png are the valid extensions.

 

Many thanks for this,

 

Rob

 

 

 

Highlighted
AppDynamics Team

Hi Robert!  Please visit the AppDynamics Support portal at https://help.appdynamics.com/hc/en-us/requests/ and "Create a New Request". 

 

This will allow you to work privately with our Support team and share your agent log zip, which you probaly wouldn't want to share here publicly.  

 

Thanks,

Matt