NET (Agent, Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

Configured .Net agent not reporting to controller

Explorer

Configured .Net agent not reporting to controller

I have a load balanced set of servers that have some .NET applications hosted. I have installed the latest version of .NET agents in these machines and configured them to work with the neccessary controller by creating applictaion , tiers ,assigning IIS application to tiers etc.

 

 

Inspite of all this , the controller does not seem to show me any details of the monitoring from the front end when i open up the site. I have confirmed the connection from the agent to controller is being successfully established.

 

I have also checked that data is being written in the log file on the client machine. 

 

Please help

Configured .Net agent not reporting to controller
3 REPLIES 3
Employee

Re: Configured .Net agent not reporting to controller

Hi udk_rulz,

 

If we understand correctly, you have installed .Net agent on the server and able to test the connection successfully trough AppDynamics  Agent Configuration tool.

After the successfull configuration,

  1. Could you please confirm, have you restarted the Agent cooredinator service and IIS/Instrumented applications process ?
  2. Do you have continuos load on the application ?

 

Please restart the  AppDynamics Agent cooredinator windows service first then restart the IIS/Instrumented applications process in sequence. After this please apply the continuos load on the application and check the behaviour if agent is reporting the data to the controller UI.

 

If you still face the issue, please attach and send us the complete DotNetAgent folder for our review. By default it is located at %ProgramData%\AppDynamics or if you have changed the default location then provide the same to troubleshoot further. This is a hidden folder and can be found at the following location:

  • Windows Server 2008 and later %ProgramData%\AppDynamics\DotNetAgent
  • Windows Server 2003 %AllUsersProfile%\Application Data\AppDynamics\DotNetAgent

 

Thanks,

Ashish.

 



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Re: Configured .Net agent not reporting to controller

Hi,

I have the same problem. I restarted the "World Wide Web Publishing Service" and "AppDynamics.Agent.Coordinator_service". I have to restart some other service? I'm on a Ms Windows 2012 R2 Server with .NET Applications.

 

Thanks

Highlighted
Employee

Re: Configured .Net agent not reporting to controller

Hi Alberto,

 

After successful installation of .Net Agent, Have you restarted the  "AppDynamics.Agent.Coordinator_service first and then IIS/instrumented application service in sequence?

If not, kindly restart services in the given sequence and after that apply the load on the applications.

 

Let us know if it helps or you are still facing the issue.

 

Thanks,

Ashish.



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.