Latest Release

cancel
Showing results for 
Search instead for 
Did you mean: 

AppD Java agent 4.4 with 4.3.5.7 controller - will it work?

SOLVED
Builder

AppD Java agent 4.4 with 4.3.5.7 controller - will it work?

Hi

we're currently using AppD 4.3.5.7 and I just read the new release notes of 4.4. The Java Agent 4.4 would have 2 very important enhancements for my use-case

  • support for the Apache Async HTTP Client
  • enhanced support for Kafka (and Akka)

My question: will I be able to profit from these enhancement by just upgradeing the agent to 4.4, but leave the controller at 4.3.5.7? Only a very small minority of the agents really need those enhancements, so I would like to upgrade only those few machines, and not the whole environment

 

Thanks!
CU, Joe

AppD Java agent 4.4 with 4.3.5.7 controller - will it work?
2 REPLIES 2
Highlighted
Builder

Re: AppD Java agent 4.4 with 4.3.5.7 controller - will it work?

Hm, I guess I don't even need to try, the notes say

 

      AppDynamics agents are not backwards compatible with the AppDynamics Controller. The Controller version must be equal to or greater than the versions of any agents connecting to it.

 

No joy, I guess...

AppDynamics Team

Re: AppD Java agent 4.4 with 4.3.5.7 controller - will it work?

You're right Joe.

You'll need to upgrade your Controller to 4.4 before you can leverage the 4.4 agents.

 

Regards,

Brian Wheeldon

Brian Wheeldon, Solution Engineer, NYC







Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Tags (2)