cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Nina.Wolinsky
AppDynamics Team

To make sure you complete all the tasks necessary for upgrading dynamic language Agents after a release, we recommend following the upgrade checklist instructions below. 

 

NOTE: The information in this article is not release-specific. You can reference it for any release

 

Table of Contents

  • Prepare to upgrade your dynamic language agent
  • Plan your dynamic language agent upgrade
  • Troubleshooting
  • Additional Resources

 

Prepare to upgrade your dynamic language agent

 

Plan your dynamic language agent upgrade

  • Starting in release 4.5, Language Agents are automatically backward-compatible with any 4.4.1+  Controller, so you can upgrade your agent while retaining your 4.4.1+ Controller. See Agent and Controller Compatibility documentation.

    Note: If your Controller is older than 4.4.1, you must upgrade your Controller before upgrading your Language Agent.

  • To ensure a successful correlation, upgrade order should begin with agents on downstream tiers, followed by those on upstream tiers.

  • If you are upgrading multiple agents in your monitored environment, be sure to upgrade last the agents for tiers on which business transactions originate.

    See the following documents for step-by-step instructions, as needed:

 

Troubleshooting

In the event of a failure, uninstall the newer agent version and reinstall the previous version. Once it has been reinstalled, restart the application.

 

Additional Resources

Instructions for upgrading other AppDynamics components are available in our general Release Upgrade Checklist

Version history
Last update:
‎10-09-2020 04:26 PM
Updated by:
On-Demand Webinar
Discover new Splunk integrations and AI innovations for Cisco AppDynamics.


Register Now!

Observe and Explore
Dive into our Community Blog for the Latest Insights and Updates!


Read the blog here