Showing results for 
Show  only  | Search instead for 
Did you mean: 

how to disable built-in GWT detection rule / disable default pojo rules



I'm having trouble overriding default transaction detection rule in GWT application.

We want the transactions to be detected by custom rule further downstream, but transactions keep beeing detected and intercepted at GWT RPC level by some default rule - from agen log:

INFO POJORuleApplier - [CustomMatchPointDefinition{businessTransactionName='GWT', matchPointRule=POJOMatchRule{matchClassType=MATCHES_CLASS, classMatch=SM{ex_type=EQUALS, ex_pattern='', type=EQUALS, pattern=''}, methodMatch=[SM{ex_type=EQUALS, ex_pattern='invokeAndEncodeResponse', type=EQUALS, pattern='invokeAndEncodeResponse'}],, splitOperationType=0, splitOperation='null', excludes=null, backgroundTask=false, displayName='GWT', splitConfig=[],[],, hashCode=null}, entryPointType=POJO, background=false, enabled=false, attachedEntity=null, agentType=APP_AGENT, matchRuleString='null'}, 

I've tried to setup custom pojo rules with high priority, but to no result.

Any suggestions?





AppDynamics Team (Retired)

Hi Ugis,


GWT is one of few frameworks that have POJO auto-discovery out-of-the-box. In order to disable it, add below element inside <bci-processing-excludes> in app-agent-config.xml file.


<custom-exclude filter-type="EQUALS" filter-value=""/>

 If you want to disable all of these frameworks that pick up POJO OOTB, then you can set/create following node property:

  • Name: framework-support
  • Type: String
  • Value: none

Thanks for info, will try out.
It would be helpful to have this information in the documentation somewhere – what are individual types of auto discovery, that can be disabled in such way. I’ve lost 2-3 days trying out things before understanding came that this auto discovery is the issue.



AppDynamics Team (Retired)

Hi Ugis,


Yes, I agree and also my opinion that this could be better documented. There were internal requests previously regarding this, but does not seem like it has been fully followed through. I'll look to follow up internally again.


Appreciate it and sorry you had to spend some additional cycles due to this.