cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Not a customer? Start a free trial

Click the Start a free trial link to start a 15-day SaaS trial of our product and join our community as a trial user. If you are an existing customer do not start a free trial.

AppDynamics customers and established members should click the sign in button to authenticate.

Java (Java Agent, Installation, JVM, and Controller Installation)

failed to attach agent to server

Amr.Gamal
Producer

failed to attach agent to server

hello , 

I'm using macOS sierra , firstly i installed  java(jdk 9.0.1) after that i installed the apache tomcat server and it worked successfully after that i followed the instructions in the video of installing java agent ; as i downloaded the agent and followed the steps but i can't attach the server to the agent due to the error (in the below screenshot):

 

Screen Shot 2017-11-13 at 2.46.21 PM.pngi noticed that tools.jar not exist in the JDK lib folder , but i don't know why and is it the problem or what ?

how can i fix this issue , please ?

Thanks

 

By replying you agree to the Terms and Conditions of the AppDynamics Community.
failed to attach agent to server
11 REPLIES 11
Peter.Holditch
Moderator

So, from the above 2282 was the pid of jps itself, which explains why you can't attach to that, since it stopped running before you tried.

 

The second process, called "bootstrap" is presumably your tomcat, so try to attach to that.  (you could see the full command line by adding the -v option to your jps command)

 

If you're having toruble connecting to the tomact dynamically, you could try to add the javaagent as a tomcat startup parameter, as documented here.



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Amr.Gamal
Producer

i executed the full command line with -v parameter and it returned 2 ids then 

i tried to execute the command of attaching the agent but it also failed with the same error with both 2 ids

 

i tried to add the javaagent as a tomcat startup parameter but no changes happened 

i'm really got frustrated , any suggestions in order to try appdynamics 

or is there another way to practice on appdynamics

 

thank

Screen Shot 2017-11-14 at 3.03.49 PM.png