Java (Java Agent, Installation, JVM, and Controller Installation)

cancel
Showing results for 
Search instead for 
Did you mean: 

failed to attach agent to server

Highlighted
Discoverer

hello , 

I'm using macOS sierra , firstly i installed  java(jdk 9.0.1) after that i installed the apache tomcat server and it worked successfully after that i followed the instructions in the video of installing java agent ; as i downloaded the agent and followed the steps but i can't attach the server to the agent due to the error (in the below screenshot):

 

Screen Shot 2017-11-13 at 2.46.21 PM.pngi noticed that tools.jar not exist in the JDK lib folder , but i don't know why and is it the problem or what ?

how can i fix this issue , please ?

Thanks

 

failed to attach agent to server
11 REPLIES 11
Highlighted
Moderator

java 9 removed tools.jar from the distribution, and also removed the -Xbootclasspath option (see the modules spec)

 

You should find that the agent will attach to your running tomcat if you simply remove this option from the command line.

 

Warm regards,
Peter



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
Discoverer

thanks peter for your support ,but i tried it but it failed also so could you tell me what needs to be modified in the command so that it can attached successfully ,the original command :

 

sudo java -Xbootclasspath/Library/Java/JavaVirtualMachines/jdk-9.0.1.jdk/Contents/Home/lib/classes.jar -jar /Users/amrgamal/Downloads/AppServerAgent-4/ver4.3.3.9/javaagent.jar

 

Best Regards 

Amr 

Highlighted
Moderator

I just noticed from the path in your command that you are using version 4.3.3.9 of the agent.

 

JDK9 support was a new feature we introduced in the 4.4 release, so you will need to upgrade to a 4.4 agent and controller, or downgrade to jdk 8 to get this working.

 

Warm regards,
Peter



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
Discoverer

i downgraded to jdk but the issue still the same as below screen shot .

is there something else i should do or check for ??

 

thanks a lot Screen Shot 2017-11-13 at 3.32.54 PM.png

 

 

 

Highlighted
Moderator

Are you sure the java command hasn't picked up the java 9 JDK?

What happens if you replace "java" with "/Library/Java/JavaVirtualMachines/jdk1.8.0_151.jdk/Contents/Home/bin/java" ?

 



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
Discoverer

yeah i'm sure i removed jdk9

the same error happened Screen Shot 2017-11-13 at 3.49.11 PM.png

 

Highlighted
Moderator

Ah, I just noticed that your bootclasspath option is slightly malformed

From the documentation, you want to run the command like this:

java -Xbootclasspath/a:<path_to_jdk>/lib/tools.jar -jar /<agent_home>/javaagent.jar <jvm_process_id>

you're missing the "/a:" part, and the process ID of your running tomcat.  Can you try adding these?



Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted
Discoverer

nice , i modified the command and get the process id but it raised an exception ,

i think the problem is in the process id , it check for it but it changed over time Screen Shot 2017-11-13 at 4.29.34 PM.png

 

Screen Shot 2017-11-13 at 4.29.26 PM.png

 

 

 

Highlighted
Discoverer

Any recommendations ??