Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to export and import custom rules


Hey all,


Been trying to export and importing custom made rules configuration through the REST API of Appdynamics.


Right now I can export all servlet custom rules through the REST API. Now I want to import the configuration XML but constantly getting an internal server error. I'm doing something wrong and I don't know what


With postman I enter the following URL:



I set the action to 'POST'


Add this in the body


<?xml version="1.0" encoding="UTF-8"?>
<custom-match-points controller-version="004-002-007-000">
		<name> another name </name>
		<business-transaction-name> The name</business-transaction-name>
				<uri filter-type="STARTSWITH" filter-value="/pages/wicket"/>
					<parameter match-type="check-for-existence">
						<name filter-type="EQUALS" filter-value="the configuration"/>


As a header I set the Content-Type to application/xml and i set the authorization tab as Basic auth and fill in needed credentials.


Click on send and boom internal server error. My guess its either the authentication (don't think so) something missing in the header (maybe) or something wrong with the body (likely). 



Can you confirm that the user you are using has access to create health rules for that application?

Or better, run it using AppDynamics root credentials.


curl -X POST --user user1@customer1:secret -F file=@uploadhealthrule.xml


user1: root

secret: AppDynamics admin password.



I'm having this same problem, were you able to find resolution?


I've tried the admin account on a brand new app, on a brand new controller so shouldn't be any permissions oddities.  


We're working through a migration from on-prem, and I've successfully been able to export/import healthrules and dashboards.  Just moved onto detection rules and getting this 500 error. 


To simplify things I tried the most basic export with curl based on the doc, that worked fine.  Then tried importing the output of that export again just using curl based on the doc and I consistently get a 500 Internal server error.