Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot Register Machine agent to an application

AppDynamics Team

So, I tried installing my machine agent and then running it, but when I try to associate it with an application I cannot. The option which says register doesn't show up on my  Controller -> AppDynamics Agents  page of the UI.

I have attached a screenshot of the page of how it looks to me. 

Steps I tried to troubleshoot:
I tried resetting the machine agent.
I tried restarting the machine agent.
I checked the log files to make sure my machine agent is running.
Machine agent was running hence, it shows up in the list, i just don't have the option to register it.
I tried entering the IP of my Application host, as unique host id.

My controller version is :



I have the same problem I think,  cannot register the machine agents under an application.  I am running on a SaaS controller with version   Have you tried clicking on Enable and then take your application from the right selection box and move it to the left?  That seems like it might be the right setting.  However when I do that,  the configuration does not seem to take.  If I click Enable again,  my application is still on the right hand side as if I never configured it.  

I did try the steps you took as well, but i have no idea why the register option doesn't show up in th UI.  I'm just stumped as to why i don't see that option. It's not even disabled, It just doesn't exist on there. I tried scouring through the documentation but was unable to find anything on it.




Do you have any application processes instrumented with an application agent running on the "appdpod2-app" machine?


To be automatically associated with an applicaton, the machine agent needs to coexist with at least one application process on its host.


If not, you can manually make the association through configuration.


Warm regards,




Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.

Hi Peter,


I do have a java agent instrumented on the application present on my "appdpod2-app"  machine.  My doubt is why am i not able to see the option which allows me to explicitly register the machine agent with an application.

I know there is  an option which allows me to associate the machine agent with and application, but for some reason I cannot see that optioin in the UI, it is just gone, I though i might be having some compatibility issues, but my controller and my machine agent are both the latest version downloads from the appdynamics download page.

 I have attached a snippet of how the option was available to me during earlier installs.