Infrastructure (Server, Network, Database)

cancel
Showing results for 
Search instead for 
Did you mean: 

How to set up a health rule with custom metrics for all servers?

How to set up a health rule with custom metrics for all servers?

Hi,

 

do you know how to set up a health rule with a custom metric for all servers?

 

I use a subgroup for the health rule.

 

The path:

Custom Metrics|*|Swap|Swap Size (not work)

 

I need:

Custom Metrics|"Hostname"|Swap|Swap Size

 

with my path, I have no data to display.

 

I'm going to try many paths for watching to see what may work or not.

 

Thx for help.

 

Bye

 

 

How to set up a health rule with custom metrics for all servers?
5 REPLIES 5
Highlighted

Re: How to set up a health rule with custom metrics for all servers?

I'm going to wait for a little to try multiple paths because after a widget test:

 

Capture.JPG

 

it works with my path *, I created health rules so fast after installed my PowerShell script, it's possible I need to wait a little time.

 

Bye

 

 

Highlighted

Re: How to set up a health rule with custom metrics for all servers?

After the wait time, the health rule is not working but the widget rule work. Why is that? What is the difference?

 

Thx for help.

 

bye

Highlighted
Architect

Re: How to set up a health rule with custom metrics for all servers?

That's a good question. As long as you're looking at the same metric, it should work in both places.





Found something helpful? Click the Accept as Solution button to help others find answers faster.
Liked something? Click the Thumbs Up button.
Highlighted

Re: How to set up a health rule with custom metrics for all servers?

thx for the answer.

Do you know if other people have had this problem?

Did you have a lab? Is it possible to try the rule in your lab? to exclude the problem from my controller?!

 

I have the impression that my controller has a problem.

 

thx for help.

 

bye

Highlighted

Re: How to set up a health rule with custom metrics for all servers?

I do something in the health rule, I uncheck the no datas option and the rules are half working.

 

For example: this is the status of my health rule:

Capture1.JPG

 

I have a server where my metric is on 0, it appears grey but it normally should appear red and my other metric is on 1 but they appear grey, why?

 

no data available where the metric is on 1 but it's available for the metric on 0. ?!?

 

thx for help