Infrastructure (Server, Network, Database)

cancel
Showing results for 
Search instead for 
Did you mean: 

Error message during machine agent installation

SOLVED
Producer

Error message during machine agent installation

Hello,

 

I've the following error message , when I try to start the machine agent  on Windows Server 2012 :

 

Wed Nov 28 17:20:43 CET 2018
com.google.inject.CreationException: Unable to create injector, see the following errors:

1) Explicit bindings are required and java.lang.String annotated with @com.google.inject.name.Named(value=defaultGlobalXmlConfigFile) is not explicitly bound.
while locating java.lang.String annotated with @com.google.inject.name.Named(value=defaultGlobalXmlConfigFile)
for parameter 4 at com.appdynamics.agent.sim.configuration.bootstrap.BootstrapConfigurationProvider.<init>(BootstrapConfigurationProvider.java:49)
at com.appdynamics.agent.sim.configuration.bootstrap.BootstrapConfigurationModule.configure(BootstrapConfigurationModule.java:66)

1 error
at com.google.inject.internal.Errors.throwCreationExceptionIfErrorsExist(Errors.java:466)
at com.google.inject.internal.InternalInjectorCreator.initializeStatically(InternalInjectorCreator.java:155)
at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:107)
at com.google.inject.Guice.createInjector(Guice.java:96)
at com.google.inject.Guice.createInjector(Guice.java:73)
at com.appdynamics.voltron.FrameworkBootstrap.createInjector(FrameworkBootstrap.java:107)
at com.appdynamics.voltron.FrameworkBootstrap.start(FrameworkBootstrap.java:162)
at com.appdynamics.voltron.FrameworkBootstrap.startAndRun(FrameworkBootstrap.java:120)
at com.appdynamics.voltron.FrameworkApplication.start(FrameworkApplication.java:31)
at com.appdynamics.agent.sim.Main.startSafe(Main.java:61)
at com.appdynamics.agent.sim.bootstrap.Bootstrap.main(Bootstrap.java:45)

 

Could you help me with this problem ?

 

Best regards,

 

José

Error message during machine agent installation
6 REPLIES 6

Re: Error message during machine agent installation

What version of the Machine Agent are you trying to install? I'm trying to update my machine agents to the most recent version (4.5.5.1784) and I'm getting the same thing.

Re: Error message during machine agent installation

I tried 4.5.6, which was released today and I get the same thing. I just went back to 4.5.4 and that one is working now.

Highlighted
Producer

Re: Error message during machine agent installation

I installed the version 4.5.5.1784 of the machine agent. After downgrading to version 4.5.2.1611 it solved my issue .

Producer

Re: Error message during machine agent installation

I am getting same error in later versions also.

What is the solution?

 

AppDynamics Controller build 4.5.4.6296

Agent Version: 4.5.6

 

[INFO] Agent logging directory set to: [C:\AppD_MCAG-4.5.6]

[main] INFO Version: HV000001: Hibernate Validator 5.3.2.Final

Could not start up the machine agent due to: Explicit bindings are required and java.lang.String annotated with @com.google.inject.name.Named(value=defaultGlobalXmlConfigFile) is not explicitely bound.

Please see startup.log in the current working directory for details.

 

 

Employee

Re: Error message during machine agent installation

Hi Jose,

 

There is a bug in the Machine Agent version 4.5.4 that causes this error on Windows Server 2012 R2  - it was triaged and fixed in the latest version (4.5.7).  It appears to be OS-specific, as we were not able to reproduce it on Windows Server 2016.  Apologies for the incovenience: please upgrade to the latest version of the Machine Agent, available from the download site and the issue should be fixed.

 

Best Regards, Mark Prichard

Seniro Director, Product Management 

Employee

Re: Error message during machine agent installation

Please see my reply to the original post - this bug was fixed in the latest (4.5.7) version of the Machine Agent, so you could also upgrade to that version.  Apologies for the inconvenience.